summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Kutsan (GitHub) <akutsan@luxoft.com>2016-12-28 12:39:34 +0200
committerGitHub <noreply@github.com>2016-12-28 12:39:34 +0200
commit7d29edc6716188776d4a5668d7960dc58724f611 (patch)
tree782ee7aa390efff299875beb11ae7360413379cb /CMakeLists.txt
parent05dc77839b259c2531ab6577e497d9d9f6661ed9 (diff)
parentf164faebab4f15d169c20d31526ab89f7f86eeed (diff)
downloadsdl_core-7d29edc6716188776d4a5668d7960dc58724f611.tar.gz
Merge pull request #1136 from LitvinenkoIra/fix/remove_mqueue_adapter
Remove MqueueAdapter from CMakeLists and life_cycle
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index deddd75cd1..3252f7071d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,9 +114,6 @@ if (HMI_ADAPTER_OPTION)
elseif (${HMI_ADAPTER_OPTION} STREQUAL "DBUS")
message(STATUS "Jenkins integration: selected HMI adapter DBUS")
set (HMIADAPTER "dbus")
- elseif (${HMI_ADAPTER_OPTION} STREQUAL "MQUEUE")
- message(STATUS "Jenkins integration: selected HMI adapter MQUEUE")
- set (HMIADAPTER "mqueue")
endif()
endif()
@@ -403,9 +400,6 @@ endif()
if (HMI STREQUAL "web" AND NOT DEFINED HMIADAPTER)
set(HMIADAPTER "messagebroker")
endif()
-if (HMI STREQUAL "no" AND NOT DEFINED HMIADAPTER)
- set(HMIADAPTER "mqueue")
-endif()
if (HMIADAPTER STREQUAL "dbus")
set(HMI_DBUS_API ON)
@@ -418,11 +412,6 @@ if (HMIADAPTER STREQUAL "messagebroker")
add_definitions(-DMESSAGEBROKER_HMIADAPTER)
add_definitions(-DHMI_JSON_API)
endif()
-if (HMIADAPTER STREQUAL "mqueue")
- set(HMI_JSON_API ON)
- add_definitions(-DMQUEUE_HMIADAPTER)
- add_definitions(-DHMI_JSON_API)
-endif()
# --- Directory with SDL interfaces, global types and ProtocolLib component
include_directories(