summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvo Stoilov (GitHub) <istoilov@luxoft.com>2017-01-03 12:49:54 +0200
committerIvo Stoilov (GitHub) <istoilov@luxoft.com>2017-01-03 12:49:54 +0200
commit82c9705d98e5cd73c1907857ba208ca5092ea9c5 (patch)
tree2e22f16d2096f8eb06f41d02123432265371311a /CMakeLists.txt
parent16a403b3cca43e4b211525f4b6c80a43466b5e97 (diff)
downloadsdl_core-82c9705d98e5cd73c1907857ba208ca5092ea9c5.tar.gz
Apply code review comments
Fixed changed to .travis.yml Restored build configuration defaults Put back/remove files changed with refactoring Reverted changes related to MSCV Removed changes related to QT_PORT Related taks APPLINK-30588 APPLINK-30972
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 3 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a4ae6509a..443164f565 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,9 +44,9 @@ option(EXTENDED_MEDIA_MODE "Turn on and off extended Madia Manager features rela
option(BUILD_SHARED_LIBS "Build all libraries as shared (if ON) or static (if OFF)" OFF)
option(BUILD_BT_SUPPORT "Bluetooth support" ON)
option(BUILD_USB_SUPPORT "libusb support" ON)
-option(BUILD_BACKTRACE_SUPPORT "backtrace support" OFF)
-option(BUILD_TESTS "Possibility to build and run tests" ON)
-option(TELEMETRY_MONITOR "Enable profiling time test util" OFF)
+option(BUILD_BACKTRACE_SUPPORT "backtrace support" ON)
+option(BUILD_TESTS "Possibility to build and run tests" OFF)
+option(TELEMETRY_MONITOR "Enable profiling time test util" ON)
option(ENABLE_LOG "Logging feature" ON)
option(ENABLE_GCOV "gcov code coverage feature" OFF)
option(ENABLE_SANITIZE "Sanitize tool" OFF)
@@ -240,14 +240,6 @@ endif()
set(CMAKE_CXX_FLAGS_RELEASE " -DNDEBUG -s -O2")
set(CMAKE_CXX_FLAGS_DEBUG " -DDEBUG -g3 -ggdb3")
-if(QT_PORT)
- set(CMAKE_AUTOMOC ON)
- find_package(Qt5 REQUIRED Core Network)
- include_directories(
- ${Qt5Core_INCLUDE_DIRS}
- ${Qt5Network_INCLUDE_DIRS})
-endif ()
-
if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
add_definitions(-DOS_LINUX)
elseif(CMAKE_SYSTEM_NAME STREQUAL "QNX")