summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSerhii Niukalov (GitHub) <36993782+SNiukalov@users.noreply.github.com>2020-02-25 21:39:41 +0200
committerGitHub <noreply@github.com>2020-02-25 14:39:41 -0500
commit8a90ed028d97239f8e304b481230fdd805d4b1ed (patch)
tree2457c2a7e28117a3d13cce4f13baadba88a6a3dd /CMakeLists.txt
parent14873b942d5e876ea119cc19846a454d06007f1f (diff)
downloadsdl_core-8a90ed028d97239f8e304b481230fdd805d4b1ed.tar.gz
Add the ability to use IAP2 transport from build flags (#3219)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 351bfb4ab6..b344f91342 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,6 +52,7 @@ option(ENABLE_GCOV "gcov code coverage feature" OFF)
option(ENABLE_SANITIZE "Sanitize tool" OFF)
option(ENABLE_SECURITY "Security Ford protocol protection" ON)
option(ENABLE_HMI_PTU_DECRYPTION "Policy table update parsed by hmi" ON)
+option(ENABLE_IAP2EMULATION "IAP2 emulation via tcp" OFF)
option(USE_COTIRE "Use Cotire to speed up build (currently only for commands tests)" ON)
option(USE_GOLD_LD "Use gold linker intead of GNU linker" ON)
option(USE_CCACHE "Turn on ccache usage" ON)
@@ -422,6 +423,11 @@ if(ENABLE_HMI_PTU_DECRYPTION)
message(STATUS "HMI PTU decription enabled")
endif()
+if(ENABLE_IAP2EMULATION)
+ add_definitions(-DENABLE_IAP2EMULATION)
+ message(STATUS "IAP2 emulation enabled")
+endif()
+
set(RTLIB rt)
if(CMAKE_SYSTEM_NAME STREQUAL "QNX")
set(RTLIB )