summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJackLivio <jack@livio.io>2021-05-21 10:42:33 -0400
committerGitHub <noreply@github.com>2021-05-21 10:42:33 -0400
commit9ac9acdec6d82b280fca5286549ea904e7bc8b4c (patch)
tree6dd928b65572dbb962aef5cdfa23bde830096651 /CMakeLists.txt
parent055bd3c4791ca73f9f6c70970119a92b864684f8 (diff)
downloadsdl_core-9ac9acdec6d82b280fca5286549ea904e7bc8b4c.tar.gz
Feature/GitHub actions ci (#3701)
* Test github action * Build Core * Fix path * Add submodules * Move path * Debug policy cmake paths * Debug lines * Change build directory * Print sources * Change core path * ls debug * Log cmake version * Try ubuntu 18 * Set Cmake version * Change cmake depdency * Remove version wildcard * Debug collect sources * More debug messages * Check filtered files * Remove bad policy path exclude * Try caching 3rd party * Fix env var * Update 3rd party path * Fix path * Remove env var * Fix space * Update path * Update core path * Fix boost install path * Add 3rd party arch path * Set LD_LIBRARY_PATH * Add check style * Fix cache path * Update README badge status * Move 3rd party build path * Remove Travis * Move cache call earlier * Fix syntax * Conditional mkdir * Add debug line * Add logs * Fix syntax * Fix syntax * Remove log lines * Use boost logger * Update cache * Remove -j * Top level boost include * Adjust boost includes * Remove boost logger * Invalidate cache * Update CMakeLists.txt * Update CMakeLists.txt * Update CMakeLists.txt * Update CMakeLists.txt * Update sdl_core_github_ci.yml * Update CMakeLists.txt * Update CMakeLists.txt * Update CMakeLists.txt * Add pull request action
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 844319ed62..07e5bd5b56 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -444,6 +444,11 @@ if(ENABLE_LOG AND ${LOGGER_NAME} STREQUAL "LOG4CXX")
include_directories ( ${LOG4CXX_INCLUDE_DIRECTORY} )
endif()
+if(ENABLE_LOG AND ${LOGGER_NAME} STREQUAL "BOOST")
+ message(STATUS "Including boost")
+ include_directories ( ${BOOST_INCLUDE_DIR} )
+endif()
+
if(ENABLE_SECURITY)
add_definitions(-DENABLE_SECURITY)
set(SecurityManagerLibrary SecurityManager)