summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJacob Keeler <jacob.keeler@livioradio.com>2019-03-29 14:14:27 -0400
committerGitHub <noreply@github.com>2019-03-29 14:14:27 -0400
commitabdfa1d970c9d965a1f05d0b26fa3b8d350bb265 (patch)
tree11114e7f40969e32a3dc659c438be7f4e744bb72 /CMakeLists.txt
parent91d2c60cd368a5c974caa8af39c4a8233409ade5 (diff)
downloadsdl_core-abdfa1d970c9d965a1f05d0b26fa3b8d350bb265.tar.gz
Fix build when ENABLE_LOG=OFF and BUILD_TESTS=ON (#2863)
* Change cmake flags to exclude some warnings from -Werror * Fix build failures with ENABLE_LOG=OFF and BUILD_TESTS=ON
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6ee77a143..38bb95c9fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -236,7 +236,8 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR})
set(ARCHIVE_OUTPUT_DIRECTORY ./bin)
-set(CMAKE_CXX_FLAGS "-fPIC -std=gnu++0x -Wall -Werror -Wuninitialized -Wvla")
+set(EXCLUDE_ERROR_FLAGS "-Wno-error=unused-variable -Wno-error=unused-but-set-variable -Wno-error=deprecated-declarations")
+set(CMAKE_CXX_FLAGS "-fPIC -std=gnu++0x -Wall -Werror ${EXCLUDE_ERROR_FLAGS} -Wuninitialized -Wvla")
if (USE_GOLD_LD)
execute_process(COMMAND ld -v OUTPUT_VARIABLE result)