summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJacob Keeler <jacob.keeler@livioradio.com>2016-07-26 10:30:15 -0400
committerJacob Keeler <jacob.keeler@livioradio.com>2016-07-26 10:32:54 -0400
commitfdf308beee4f25b4b883194dd5c9c2ad0f46b904 (patch)
tree19beb0e27d26d592beb5eacd87024b62447a613f /CMakeLists.txt
parent0843cf4323fe0c177fb9b211357c6c35112e1147 (diff)
downloadsdl_core-fdf308beee4f25b4b883194dd5c9c2ad0f46b904.tar.gz
Check for OpenSSL and UDev while running cmakehotfix/cmake_check_for_udev_openssl
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d63531e75..c42cf545b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -199,6 +199,7 @@ endif()
if (BUILD_USB_SUPPORT)
add_definitions(-DUSB_SUPPORT)
+ find_package(UDev REQUIRED)
message(STATUS "USB support is enabled")
endif()
@@ -614,6 +615,7 @@ add_custom_target(install-3rd_party
WORKING_DIRECTORY ${3RD_PARTY_BINARY_DIRECTORY}
)
+find_package(OpenSSL REQUIRED)
if(ENABLE_LOG)
include_directories ( ${LOG4CXX_INCLUDE_DIRECTORY} )
endif()