summaryrefslogtreecommitdiff
path: root/src/components/application_manager/CMakeLists.txt
diff options
context:
space:
mode:
authorValerii <vmalkov@luxoft.com>2018-02-07 16:42:01 +0200
committerIra Lytvynenko (GitHub) <ILytvynenko@luxoft.com>2018-06-26 12:01:44 +0300
commit376c972ba76aa042fbd17f36cce9518d57d7b52d (patch)
tree342cc9d88aa8f0c9cb9d2746b4676678906691d7 /src/components/application_manager/CMakeLists.txt
parent2294f0ba776c8dbb9a903ff567d53e91a059b906 (diff)
downloadsdl_core-376c972ba76aa042fbd17f36cce9518d57d7b52d.tar.gz
Fix build with unit tests after commands factory refactoring
- Change enum name from command origin to command source - Create Mock for command factory class - Fix mock_app_manager after refactoring - Fix failed unit test Fix unit test in progress Add asser in plugin manager getter Fixed UT Application manager impl -Add method "SetRPCService" into the class ApplicationManagerImpl Fixed UT Application manager impl -Add method "SetRPCService" into the class ApplicationManagerImpl Fixed UT Application manager impl -Add method "SetRPCService" into the class ApplicationManagerImpl Fixed UTs for hmi and mobile commands.
Diffstat (limited to 'src/components/application_manager/CMakeLists.txt')
-rw-r--r--src/components/application_manager/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/components/application_manager/CMakeLists.txt b/src/components/application_manager/CMakeLists.txt
index b3af800987..0e45582bb6 100644
--- a/src/components/application_manager/CMakeLists.txt
+++ b/src/components/application_manager/CMakeLists.txt
@@ -188,7 +188,7 @@ if(ENABLE_LOG)
list(APPEND LIBRARIES log4cxx -L${LOG4CXX_LIBS_DIRECTORY})
endif()
-add_dependencies("ApplicationManager" libbson)
+#add_dependencies("ApplicationManager" libbson)
target_link_libraries("ApplicationManager" ${LIBRARIES})
if(BUILD_TESTS)