summaryrefslogtreecommitdiff
path: root/src/components/application_manager/CMakeLists.txt
diff options
context:
space:
mode:
authorHerasym Oleh <oolleehh@gmail.com>2016-03-24 15:27:24 +0200
committerHerasym Oleh <oolleehh@gmail.com>2016-04-13 09:05:33 +0300
commit47e02bf586513eccb2ba00656a17b237efb1442c (patch)
treecf4f5299ae809896e803f1f03f87d8f857b5e73a /src/components/application_manager/CMakeLists.txt
parent021ed56b19de2f284908d09b74bf2ca39ff76a9e (diff)
downloadsdl_core-47e02bf586513eccb2ba00656a17b237efb1442c.tar.gz
Add implementation SubscribeWayPoints&UnsubsribeWayPoints
Add mobile request/response SubscribeWayPoints Add mobile request/response UnSubscribeWayPoints Add HMI request/response SubscribeWayPoints Add HMI request/response UnsubscribeWayPoints Add SendUnsubscribeWayPoints method in MessageHelper Add save subscribe app status to resumption DB & json Add Sending UnsubscribeWayPoints in case unexpected disconnect Related: APPLINK-21629 Conflicts: src/components/application_manager/src/application_manager_impl.cc
Diffstat (limited to 'src/components/application_manager/CMakeLists.txt')
-rw-r--r--src/components/application_manager/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/components/application_manager/CMakeLists.txt b/src/components/application_manager/CMakeLists.txt
index 963899e809..db8d2d3c79 100644
--- a/src/components/application_manager/CMakeLists.txt
+++ b/src/components/application_manager/CMakeLists.txt
@@ -237,6 +237,10 @@ file (GLOB MOBILE_COMMANDS_SOURCES
${AM_SOURCE_DIR}/src/commands/hmi/navi_show_constant_tbt_response.cc
${AM_SOURCE_DIR}/src/commands/hmi/navi_send_location_request.cc
${AM_SOURCE_DIR}/src/commands/hmi/navi_send_location_response.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/navi_subscribe_way_points_request.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/navi_subscribe_way_points_response.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/navi_unsubscribe_way_points_request.cc
+ ${AM_SOURCE_DIR}/src/commands/hmi/navi_unsubscribe_way_points_response.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_ready_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_system_context_notification.cc
${AM_SOURCE_DIR}/src/commands/hmi/on_device_chosen_notification.cc