summaryrefslogtreecommitdiff
path: root/src/components/dbus/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Kutsan (GitHub) <akutsan@luxoft.com>2017-01-05 15:18:10 +0200
committerGitHub <noreply@github.com>2017-01-05 15:18:10 +0200
commitc0201b2eb983eb963f53fc23266c0e5cfae9f708 (patch)
tree8b451b5772dd5d3aed43739ef47fb34b857a7628 /src/components/dbus/test/CMakeLists.txt
parent15fc6572395056b43cd6fbf23737048772daa350 (diff)
downloadsdl_core-c0201b2eb983eb963f53fc23266c0e5cfae9f708.tar.gz
Revert "Fix/cmake files refactoring"revert-1144-fix/cmake_files_refactoring
Diffstat (limited to 'src/components/dbus/test/CMakeLists.txt')
-rw-r--r--src/components/dbus/test/CMakeLists.txt19
1 files changed, 10 insertions, 9 deletions
diff --git a/src/components/dbus/test/CMakeLists.txt b/src/components/dbus/test/CMakeLists.txt
index 1b3df2c0e7..d96f2388fb 100644
--- a/src/components/dbus/test/CMakeLists.txt
+++ b/src/components/dbus/test/CMakeLists.txt
@@ -28,20 +28,13 @@
# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
# POSSIBILITY OF SUCH DAMAGE.
-include(${CMAKE_SOURCE_DIR}/tools/cmake/helpers/sources.cmake)
+if(BUILD_TESTS)
include_directories (
${GMOCK_INCLUDE_DIRECTORY}
${COMPONENTS_DIR}/dbus/include/
)
-#FIXME: exclude some tests
-set (EXCLUDE_PATHS
- test_dbus_message_controller.cc
-)
-
-collect_sources(SOURCES "${CMAKE_CURRENT_SOURCE_DIR}" ${EXCLUDE_PATHS})
-
set (LIBRARIES
gmock
DBus
@@ -49,4 +42,12 @@ set (LIBRARIES
SmartObjects
)
-create_test(test_DBus_test "${SOURCES}" "${LIBRARIES}")
+set(testSources
+ ${COMPONENTS_DIR}/dbus/test/test_schema.cc
+ ${COMPONENTS_DIR}/dbus/test/test_dbus_adapter.cc
+)
+
+create_test("test_DBus_test" "${testSources}" "${LIBRARIES}")
+
+endif()
+