summaryrefslogtreecommitdiff
path: root/src/components/hmi_message_handler/CMakeLists.txt
diff options
context:
space:
mode:
authorJackLivio <jack@livio.io>2018-02-02 12:00:25 -0500
committerJackLivio <jack@livio.io>2018-02-02 12:00:25 -0500
commitb12728724da99ff832ee57af5c105910732e8760 (patch)
tree68f8d4d4328dbd288649e3ba5a543544abda2de5 /src/components/hmi_message_handler/CMakeLists.txt
parentdfe8b5ef72fc97c8c60b85006704e4d42d97d34e (diff)
downloadsdl_core-b12728724da99ff832ee57af5c105910732e8760.tar.gz
Add Boost Websocket HMI Adapter
Repleaces old message broker with new boost::beast websocket library. No changes required for setup or connecting with HMI.
Diffstat (limited to 'src/components/hmi_message_handler/CMakeLists.txt')
-rw-r--r--src/components/hmi_message_handler/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/components/hmi_message_handler/CMakeLists.txt b/src/components/hmi_message_handler/CMakeLists.txt
index c1dfca5e67..4d799b92dd 100644
--- a/src/components/hmi_message_handler/CMakeLists.txt
+++ b/src/components/hmi_message_handler/CMakeLists.txt
@@ -46,13 +46,19 @@ include_directories (
${COMPONENTS_DIR}/dbus/include/
${CMAKE_SOURCE_DIR}/
${LOG4CXX_INCLUDE_DIRECTORY}
+ ${COMPONENTS_DIR}/hmi_message_handler/include
+ ${COMPONENTS_DIR}/hmi_message_handler/src
+ ${BOOST_INCLUDE_DIR}
)
set(PATHS
${CMAKE_CURRENT_SOURCE_DIR}/include
${CMAKE_CURRENT_SOURCE_DIR}/src
+
)
+message(${PATHS})
+
if (HMIADAPTER STREQUAL "dbus")
set(EXCLUDE_PATHS)
set(DBUS_ADAPTER DBus)
@@ -73,7 +79,13 @@ set(LIBRARIES
${RTLIB}
)
+
add_library("HMIMessageHandler" ${SOURCES})
+
+if (HMIADAPTER STREQUAL "messagebroker")
+ add_dependencies("HMIMessageHandler" Boost)
+endif()
+
target_link_libraries("HMIMessageHandler" ${LIBRARIES})
if(ENABLE_LOG)