summaryrefslogtreecommitdiff
path: root/src/components/security_manager/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Kutsan (GitHub) <akutsan@luxoft.com>2017-01-05 15:18:10 +0200
committerGitHub <noreply@github.com>2017-01-05 15:18:10 +0200
commitc0201b2eb983eb963f53fc23266c0e5cfae9f708 (patch)
tree8b451b5772dd5d3aed43739ef47fb34b857a7628 /src/components/security_manager/CMakeLists.txt
parent15fc6572395056b43cd6fbf23737048772daa350 (diff)
downloadsdl_core-c0201b2eb983eb963f53fc23266c0e5cfae9f708.tar.gz
Revert "Fix/cmake files refactoring"revert-1144-fix/cmake_files_refactoring
Diffstat (limited to 'src/components/security_manager/CMakeLists.txt')
-rw-r--r--src/components/security_manager/CMakeLists.txt25
1 files changed, 8 insertions, 17 deletions
diff --git a/src/components/security_manager/CMakeLists.txt b/src/components/security_manager/CMakeLists.txt
index bb50ad50c9..3cc6178931 100644
--- a/src/components/security_manager/CMakeLists.txt
+++ b/src/components/security_manager/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2015, Ford Motor Company
+# Copyright (c) 2014, Ford Motor Company
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -27,9 +27,7 @@
# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
# POSSIBILITY OF SUCH DAMAGE.
-
-
-include(${CMAKE_SOURCE_DIR}/tools/cmake/helpers/sources.cmake)
+
include_directories(
include/
@@ -43,22 +41,15 @@ include_directories(
${APR_INCLUDE_DIRECTORY}
)
-set(PATHS
- ${CMAKE_CURRENT_SOURCE_DIR}/include
- ${CMAKE_CURRENT_SOURCE_DIR}/src
-)
-collect_sources(SOURCES "${PATHS}")
-
-set(LIBRARIES
- crypto
- ssl
- ProtocolHandler
- jsoncpp
- ProtocolLibrary
+set (SOURCES
+ ${COMPONENTS_DIR}/security_manager/src/security_manager_impl.cc
+ ${COMPONENTS_DIR}/security_manager/src/security_query.cc
+ ${COMPONENTS_DIR}/security_manager/src/crypto_manager_impl.cc
+ ${COMPONENTS_DIR}/security_manager/src/ssl_context_impl.cc
)
add_library(SecurityManager ${SOURCES})
-target_link_libraries(SecurityManager ${LIBRARIES})
+target_link_libraries(SecurityManager crypto ssl ProtocolHandler jsoncpp ProtocolLibrary)
if(BUILD_TESTS)
add_subdirectory(test)