summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorHerasym Oleh <oolleehh@gmail.com>2015-12-25 12:30:50 +0200
committerHerasym Oleh <oolleehh@gmail.com>2015-12-25 12:30:50 +0200
commit3db17ce4390bdf66c8048095e39cb3350280e1be (patch)
tree116c28bbbd46bd557ddfa1204c983ab526dbb955 /tools/CMakeLists.txt
parent193bfe7d37c59a68b23a1007ba37eb19271d45ef (diff)
downloadsdl_core-3db17ce4390bdf66c8048095e39cb3350280e1be.tar.gz
Add tests in tools & 3rd-party-static.
Add tests in 3rd-party-static/test/. Add tests in tools/intergern/test/. Add tests in tools/policy_table_validator/. Related: APPLINK-20109
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 2834dce387..557c23f4e7 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -20,3 +20,8 @@ ExternalProject_Add_Step(intergen forcebuild
COMMAND ${CMAKE_COMMAND} -E echo "Force intergen build"
DEPENDEES update DEPENDERS build
ALWAYS 1)
+
+if(BUILD_TESTS)
+ add_subdirectory(intergen/test)
+endif()
+add_subdirectory(policy_table_validator)