summaryrefslogtreecommitdiff
path: root/src/3rd_party-static/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rd_party-static/test/CMakeLists.txt')
-rw-r--r--src/3rd_party-static/test/CMakeLists.txt15
1 files changed, 10 insertions, 5 deletions
diff --git a/src/3rd_party-static/test/CMakeLists.txt b/src/3rd_party-static/test/CMakeLists.txt
index a38a392a01..33bcd82694 100644
--- a/src/3rd_party-static/test/CMakeLists.txt
+++ b/src/3rd_party-static/test/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2016, Ford Motor Company
+# Copyright (c) 2015, Ford Motor Company
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -28,16 +28,21 @@
# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
# POSSIBILITY OF SUCH DAMAGE.
-include_directories(
+if(BUILD_TESTS)
+include_directories (
${GMOCK_INCLUDE_DIRECTORY}
${JSONCPP_INCLUDE_DIRECTORY}
)
-collect_sources(SOURCES "${CMAKE_CURRENT_SOURCE_DIR}")
-
set(LIBRARIES
gmock
jsoncpp
)
-create_test(jsoncpp_test "${SOURCES}" "${LIBRARIES}")
+set (SOURCES
+ json_reader_test.cc
+)
+
+add_library("test_JSONCPPTest" ${SOURCES})
+create_test("test_JSONCPP" "${SOURCES}" "${LIBRARIES}")
+endif() \ No newline at end of file