summaryrefslogtreecommitdiff
path: root/src/3rd_party/bson_c_lib/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rd_party/bson_c_lib/configure.ac')
-rw-r--r--src/3rd_party/bson_c_lib/configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/3rd_party/bson_c_lib/configure.ac b/src/3rd_party/bson_c_lib/configure.ac
new file mode 100644
index 0000000000..c883034ebb
--- /dev/null
+++ b/src/3rd_party/bson_c_lib/configure.ac
@@ -0,0 +1,33 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT(bson_c_lib, 0.1, jacob@livio.io)
+AM_INIT_AUTOMAKE
+LT_INIT
+AC_CONFIG_SRCDIR([examples/sample.c])
+AC_CONFIG_HEADERS([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+
+# Checks for libraries.
+AC_ENABLE_SHARED
+AC_DISABLE_STATIC
+
+# Checks for header files.
+AC_CHECK_HEADERS([stddef.h stdint.h stdlib.h string.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_HEADER_STDBOOL
+AC_TYPE_INT32_T
+AC_TYPE_INT64_T
+AC_TYPE_SIZE_T
+AC_TYPE_UINT64_T
+AC_TYPE_UINT8_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_CHECK_FUNCS([memset])
+
+AC_OUTPUT(Makefile src/Makefile src/emhashmap/Makefile)