summaryrefslogtreecommitdiff
path: root/src/3rd_party/bson_c_lib/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rd_party/bson_c_lib/src/Makefile.am')
-rw-r--r--src/3rd_party/bson_c_lib/src/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/3rd_party/bson_c_lib/src/Makefile.am b/src/3rd_party/bson_c_lib/src/Makefile.am
new file mode 100644
index 0000000000..81807aa62d
--- /dev/null
+++ b/src/3rd_party/bson_c_lib/src/Makefile.am
@@ -0,0 +1,11 @@
+SUBDIRS = emhashmap
+
+AM_CFLAGS = -Wall
+AM_LDFLAGS = -lemhashmap
+
+includedir = /usr/local/include
+include_HEADERS = bson_object.h bson_array.h bson_util.h
+
+lib_LTLIBRARIES = libbson.la
+libbson_la_SOURCES = bson_object.c bson_array.c bson_util.c
+libbson_la_LIBADD = emhashmap/libemhashmap.la