summaryrefslogtreecommitdiff
path: root/src/components/application_manager/test/commands/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/application_manager/test/commands/CMakeLists.txt')
-rw-r--r--src/components/application_manager/test/commands/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/components/application_manager/test/commands/CMakeLists.txt b/src/components/application_manager/test/commands/CMakeLists.txt
index cc16e4d87b..8dafc16471 100644
--- a/src/components/application_manager/test/commands/CMakeLists.txt
+++ b/src/components/application_manager/test/commands/CMakeLists.txt
@@ -46,6 +46,7 @@ set(COMMANDS_TEST_DIR ${AM_TEST_DIR}/commands)
file(GLOB SOURCES
${COMMANDS_TEST_DIR}/*
${COMPONENTS_DIR}/application_manager/test/mock_message_helper.cc
+ ${COMPONENTS_DIR}/application_manager/test/mock_application_helper.cc
${COMPONENTS_DIR}/application_manager/src/smart_object_keys.cc
${COMPONENTS_DIR}/application_manager/src/message.cc
${COMMANDS_TEST_DIR}/hmi/*
@@ -57,13 +58,13 @@ set(LIBRARIES
gmock
Utils
SmartObjects
- jsoncpp
HMI_API
MOBILE_API
ApplicationManager
AMHMICommandsLibrary
AMMobileCommandsLibrary
connectionHandler
+ jsoncpp
)
create_cotired_test("commands_test" "${SOURCES}" "${LIBRARIES}" )