summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c3062e2..7711693 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -154,6 +154,12 @@ int main() {
}" HAVE_BUILTIN_CTZ)
check_cxx_source_compiles("
+int main() {
+ __builtin_prefetch(0, 0, 3);
+ return 0;
+}" HAVE_BUILTIN_PREFETCH)
+
+check_cxx_source_compiles("
__attribute__((always_inline)) int zero() { return 0; }
int main() {