summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorsnappy.mirrorbot@gmail.com <snappy.mirrorbot@gmail.com@03e5f5b5-db94-4691-08a0-1a8bf15f6143>2011-03-23 11:11:54 +0000
committersnappy.mirrorbot@gmail.com <snappy.mirrorbot@gmail.com@03e5f5b5-db94-4691-08a0-1a8bf15f6143>2011-03-23 11:11:54 +0000
commit7dad5700705df3ff792f38bb8ee7c6381d50c8b8 (patch)
treea5e0277b8c4e56ee81aa4a4043414ea032b92db4 /configure.ac
parentafc14d5ab1f768fcd490d5d2f1602128b7438634 (diff)
downloadsnappy-7dad5700705df3ff792f38bb8ee7c6381d50c8b8.tar.gz
Fix public issue #7: Don't use internal variables named ac_*, as those belong
to autoconf's namespace. R=csilvers DELTA=6 (0 added, 0 deleted, 6 changed) Revision created by MOE tool push_codebase. MOE_MIGRATION=988 git-svn-id: http://snappy.googlecode.com/svn/trunk@6 03e5f5b5-db94-4691-08a0-1a8bf15f6143
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index b6fa77a..72301b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,13 +33,13 @@ AC_MSG_CHECKING([if the compiler supports __builtin_expect])
AC_TRY_COMPILE(, [
return __builtin_expect(1, 1) ? 1 : 0
], [
- ac_have_builtin_expect=yes
+ snappy_have_builtin_expect=yes
AC_MSG_RESULT([yes])
], [
- ac_have_builtin_expect=no
+ snappy_have_builtin_expect=no
AC_MSG_RESULT([no])
])
-if test x$ac_have_builtin_expect = xyes ; then
+if test x$snappy_have_builtin_expect = xyes ; then
AC_DEFINE(HAVE_BUILTIN_EXPECT, 1, [Define to 1 if the compiler supports __builtin_expect.])
fi
@@ -50,13 +50,13 @@ AC_MSG_CHECKING([if the compiler supports __builtin_ctzll])
AC_TRY_COMPILE(, [
return (__builtin_ctzll(0x100000000LL) == 32) ? 1 : 0
], [
- ac_have_builtin_ctz=yes
+ snappy_have_builtin_ctz=yes
AC_MSG_RESULT([yes])
], [
- ac_have_builtin_ctz=no
+ snappy_have_builtin_ctz=no
AC_MSG_RESULT([no])
])
-if test x$ac_have_builtin_ctz = xyes ; then
+if test x$snappy_have_builtin_ctz = xyes ; then
AC_DEFINE(HAVE_BUILTIN_CTZ, 1, [Define to 1 if the compiler supports __builtin_ctz and friends.])
fi