summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorsnappy.mirrorbot@gmail.com <snappy.mirrorbot@gmail.com@03e5f5b5-db94-4691-08a0-1a8bf15f6143>2011-09-15 09:50:05 +0000
committersnappy.mirrorbot@gmail.com <snappy.mirrorbot@gmail.com@03e5f5b5-db94-4691-08a0-1a8bf15f6143>2011-09-15 09:50:05 +0000
commit85ec6d0ce7742833cc8f8d43a8120e42163e655c (patch)
tree38f4f3a6dc27891d5db4772e6a15e46b69111ca2 /configure.ac
parent0493f8d450c8b28b455d969e5e1047b7917c6677 (diff)
downloadsnappy-85ec6d0ce7742833cc8f8d43a8120e42163e655c.tar.gz
Fix public issue #50: Include generic byteswap macros.
Also include Solaris 10 and FreeBSD versions. R=csilvers git-svn-id: http://snappy.googlecode.com/svn/trunk@49 03e5f5b5-db94-4691-08a0-1a8bf15f6143
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 38c4a52..43fa0ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,7 +18,7 @@ AC_SUBST([LIBTOOL_DEPS])
AC_PROG_CXX
AC_LANG([C++])
AC_C_BIGENDIAN
-AC_CHECK_HEADERS([stdint.h stddef.h sys/mman.h sys/resource.h windows.h])
+AC_CHECK_HEADERS([stdint.h stddef.h sys/mman.h sys/resource.h windows.h byteswap.h sys/byteswap.h sys/endian.h])
# Don't use AC_FUNC_MMAP, as it checks for mappings of already-mapped memory,
# which we don't need (and does not exist on Windows).