summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorsnappy.mirrorbot@gmail.com <snappy.mirrorbot@gmail.com@03e5f5b5-db94-4691-08a0-1a8bf15f6143>2011-03-24 19:12:27 +0000
committersnappy.mirrorbot@gmail.com <snappy.mirrorbot@gmail.com@03e5f5b5-db94-4691-08a0-1a8bf15f6143>2011-03-24 19:12:27 +0000
commita86c963d9fce9d95aa69e622c153cdcc4de09f70 (patch)
tree87da1ab83835ec50909fdf8db1a835f3970c44c5 /configure.ac
parent943b85083ee43a7bba396d8153b98aeadb177786 (diff)
downloadsnappy-a86c963d9fce9d95aa69e622c153cdcc4de09f70.tar.gz
Make the unit test work on systems without mmap(). This is required for,
among others, Windows support. For Windows in specific, we could have used CreateFileMapping/MapViewOfFile, but this should at least get us a bit closer to compiling, and is of course also relevant for embedded systems with no MMU. (Part 1/2) R=csilvers DELTA=9 (8 added, 0 deleted, 1 changed) Revision created by MOE tool push_codebase. MOE_MIGRATION=1031 git-svn-id: http://snappy.googlecode.com/svn/trunk@15 03e5f5b5-db94-4691-08a0-1a8bf15f6143
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7081445..4e938d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,7 +18,7 @@ AC_SUBST([LIBTOOL_DEPS])
AC_PROG_CXX
AC_LANG([C++])
AC_C_BIGENDIAN
-AC_CHECK_HEADERS([stdint.h stddef.h])
+AC_CHECK_HEADERS([stdint.h stddef.h sys/mman.h])
# Don't use AC_FUNC_MMAP, as it checks for mappings of already-mapped memory,
# which we don't need (and does not exist on Windows).