summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..e5f7591
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,25 @@
+## Process this file with automake to produce Makefile.in. -*-Makefile-*-
+
+# $Id: Makefile.am,v 1.11 2004/02/18 06:59:40 jm Exp $
+
+# Disable automatic dependency tracking if using other tools than gcc and gmake
+#AUTOMAKE_OPTIONS = no-dependencies
+
+INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) @OGG_CFLAGS@
+
+man_MANS = speexenc.1 speexdec.1
+
+EXTRA_DIST = $(man_MANS) getopt_win.h getopt.c getopt1.c wave_out.c wave_out.h skeleton.h
+
+include_HEADERS =
+noinst_HEADERS = wav_io.h
+
+bin_PROGRAMS = speexenc speexdec
+
+speexenc_SOURCES = speexenc.c wav_io.c skeleton.c
+speexenc_LDADD = $(top_builddir)/libspeex/libspeex.la $(top_builddir)/libspeex/libspeexdsp.la \
+ $(OGG_LIBS) @FFT_LIBS@
+
+speexdec_SOURCES = speexdec.c wav_io.c
+speexdec_LDADD = $(top_builddir)/libspeex/libspeex.la \
+ $(OGG_LIBS) @FFT_LIBS@