summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAdam Spiers <stow@adamspiers.org>2015-11-09 11:36:11 +0000
committerAdam Spiers <stow@adamspiers.org>2015-11-09 12:36:51 +0000
commit43333b8ecafffdcd6345710b034fb26ea6898e05 (patch)
treeee91a33d4d5e88560299c01a7a43c54516a645a1 /Makefile.am
parentd82b6aa1a8677fb7140a9a6daa934f250859b947 (diff)
downloadstow-43333b8ecafffdcd6345710b034fb26ea6898e05.tar.gz
add Stow/Util.pm.in with @VERSION@ substitution
This is now necessary in order to prevent pause.perl.org from complaining: Status: Decreasing version number ================================= module : Stow::Util version: undef in file: lib/Stow/Util.pm status : Not indexed because lib/Stow/Util.pm in A/AS/ASPIERS/Stow-v2.2.0.tar.gz has a higher version number (0)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2cea9a6..3303a6a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,7 +75,7 @@ $(TESTS_OUT):
CPAN_FILES = MANIFEST MANIFEST.SKIP Build.PL META.yml META.json
EXTRA_DIST = \
- bin/stow.in bin/chkstow.in lib/Stow.pm.in \
+ bin/stow.in bin/chkstow.in lib/Stow.pm.in lib/Stow/Util.pm.in \
doc/manual-split \
$(TESTS) t/testutil.pm \
$(TEXINFO_TEX) \
@@ -140,6 +140,11 @@ lib/Stow.pm: lib/Stow.pm.in $(DEFAULT_IGNORE_LIST) Makefile
@( $(edit) < $<; cat $(DEFAULT_IGNORE_LIST) ) > $@
@echo "Generated $@ from $< and $(DEFAULT_IGNORE_LIST)"
+lib/Stow/Util.pm: lib/Stow/Util.pm.in Makefile.am
+ @[ -d lib/Stow ] || mkdir -p lib/Stow # required in vpath mode
+ @$(edit) < $< > $@
+ @echo "Generated $@ from $<"
+
##############################################################################
# The below rules should only be needed by developers.
##############################################################################