summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Spiers <stow@adamspiers.org>2011-12-07 20:31:18 +0000
committerAdam Spiers <stow@adamspiers.org>2011-12-07 20:31:18 +0000
commitd88434f16eb204c888723c755f9ade555fc3feb2 (patch)
tree908c5cdc04c285d62573f1a214244738a23ea535 /configure.ac
parente7e0646db0869a8c4e45586c3f1904248a369c14 (diff)
downloadstow-d88434f16eb204c888723c755f9ade555fc3feb2.tar.gz
Abort ./configure if we can't find Perl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index cd851d9..d88c826 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,12 +9,12 @@ AC_CONFIG_AUX_DIR([automake])
AM_INIT_AUTOMAKE([-Wall -Werror -Wno-override dist-bzip2])
AC_PROG_INSTALL
-dnl Check for perl on our system
-dnl call to AC_SUBST(PERL) is implicit
+dnl Check for perl on our system.
+dnl Call to AC_SUBST(PERL) is implicit
AC_PATH_PROGS([PERL], [perl] [perl5], [false])
if test "x$PERL" = xfalse
then
- AC_MSG_WARN([WARNING: Perl not found; you must edit line 1 of 'stow'])
+ AC_MSG_ERROR([Perl not found; check your \$PATH.])
fi
AC_ARG_WITH(