summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@strace.io>2023-05-15 08:00:00 +0000
committerDmitry V. Levin <ldv@strace.io>2023-05-15 08:00:00 +0000
commit8f691206e4aa769cc99e264f1c15ae6956789f91 (patch)
tree185531b240ddebc95c7d7f255594be144aca755f /configure.ac
parent206c58a9ab53e47cf85227a7c2ee6c6ef7f0c0d5 (diff)
downloadstrace-master.tar.gz
configure: do not take the SUBLEVEL part of the kernel version into accountHEADmaster
* configure.ac: When deciding whether to use bundled version of kernel headers, ignore the SUBLEVEL part of the kernel version, assuming that any potential changes in UAPI introduced in stable kernels are not important. Resolves: https://github.com/strace/strace/issues/253
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index efd0632e8..f12ad7a72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -278,7 +278,7 @@ AC_CACHE_CHECK(
[AS_IF([test $enable_bundled = check],
[AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM([#include <linux/version.h>
-#define USE_OS_HEADERS (LINUX_VERSION_CODE > ]linux_version_code[ ? 1 : -1)],
+#define USE_OS_HEADERS ((LINUX_VERSION_CODE >> 8) > (]linux_version_code[ >> 8) ? 1 : -1)],
[[int i[USE_OS_HEADERS];]]
)
],