summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTodd C. Miller <Todd.Miller@sudo.ws>2022-12-30 13:38:40 -0700
committerTodd C. Miller <Todd.Miller@sudo.ws>2022-12-30 13:38:40 -0700
commit64c2a167253659f07c0a43bd441c082869941fc0 (patch)
treea5870fa6f7d4068f534a48eae87b39de7913ac94 /configure.ac
parent9b0194f907ad1615ca4ab5b72e738901a2f60c94 (diff)
downloadsudo-64c2a167253659f07c0a43bd441c082869941fc0.tar.gz
Substitute python plugin file name in sudo_plugin_python documentation.
Also use prefix for group plugin fallback path section in sudoers manual.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 25abf27f0..b734ed913 100644
--- a/configure.ac
+++ b/configure.ac
@@ -179,6 +179,7 @@ AC_SUBST([pam_session])
AC_SUBST([pam_login_service])
AC_SUBST([plugindir])
AC_SUBST([sudoers_plugin])
+AC_SUBST([python_plugin])
#
# Begin initial values for man page substitution
#
@@ -228,6 +229,7 @@ pam_session=on
pam_login_service=sudo
plugindir="$libexecdir/sudo"
sudoers_plugin="sudoers.so"
+python_plugin="python_plugin.so"
DIGEST=digest.lo
devsearch="/dev/pts:/dev/vt:/dev/term:/dev/zcons:/dev/pty:/dev"
#
@@ -1685,6 +1687,7 @@ aix*)
noexec_file="$libexecdir/sudo/sudo_noexec.a(sudo_noexec.so)"
intercept_file="$libexecdir/sudo/sudo_intercept.a(sudo_intercept.so)"
sudoers_plugin="sudoers.a(sudoers.so)"
+ python_plugin="python_plugin.a(python_plugin.so)"
fi
;;
esac
@@ -4424,6 +4427,9 @@ echo " Pathnames:" >&AS_MESSAGE_FD
echo " log directory : ${log_dir}" >&AS_MESSAGE_FD
echo " plugin directory : ${plugindir}" >&AS_MESSAGE_FD
echo " sudoers plugin : ${sudoers_plugin}" >&AS_MESSAGE_FD
+if test "${enable_python-no}" != "no"; then
+ echo " python plugin : ${python_plugin}" >&AS_MESSAGE_FD
+fi
echo " run directory : ${rundir}" >&AS_MESSAGE_FD
echo " var directory : ${vardir}" >&AS_MESSAGE_FD
echo " I/O log directory : ${iolog_dir}" >&AS_MESSAGE_FD