summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTodd C. Miller <Todd.Miller@sudo.ws>2022-04-01 11:14:59 -0600
committerTodd C. Miller <Todd.Miller@sudo.ws>2022-04-01 11:14:59 -0600
commit742b8f544a6d69e23f70b1d5b53862e30432bea9 (patch)
treef20b471af984c0157b7f1a8b4df17b092055521c /configure.ac
parent62a634b15593b41131a2727be2ece7f24270ed7e (diff)
downloadsudo-742b8f544a6d69e23f70b1d5b53862e30432bea9.tar.gz
Rename SSP_(C|LD)FLAGS -> HARDENING_(C|LD)FLAGS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 05e68363f..c2a69d28e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,8 +107,8 @@ AC_SUBST([ASAN_LDFLAGS])
AC_SUBST([ASAN_CFLAGS])
AC_SUBST([PIE_LDFLAGS])
AC_SUBST([PIE_CFLAGS])
-AC_SUBST([SSP_LDFLAGS])
-AC_SUBST([SSP_CFLAGS])
+AC_SUBST([HARDENING_LDFLAGS])
+AC_SUBST([HARDENING_CFLAGS])
AC_SUBST([INIT_SCRIPT])
AC_SUBST([INIT_DIR])
AC_SUBST([RC_LINK])
@@ -4893,18 +4893,18 @@ if test "$enable_hardening" != "no" && test "$enable_ssp" != "no"; then
]
)
if test X"$sudo_cv_var_stack_protector" != X"no"; then
- SSP_CFLAGS="$sudo_cv_var_stack_protector"
- SSP_LDFLAGS="-Wc,$sudo_cv_var_stack_protector"
+ HARDENING_CFLAGS="$sudo_cv_var_stack_protector"
+ HARDENING_LDFLAGS="-Wc,$sudo_cv_var_stack_protector"
fi
fi
if test "$enable_hardening" != "no"; then
AX_CHECK_LINK_FLAG([-fstack-clash-protection], [
- AX_APPEND_FLAG([-fstack-clash-protection], [SSP_CFLAGS])
- AX_APPEND_FLAG([-Wc,-fstack-clash-protection], [SSP_LDFLAGS])
+ AX_APPEND_FLAG([-fstack-clash-protection], [HARDENING_CFLAGS])
+ AX_APPEND_FLAG([-Wc,-fstack-clash-protection], [HARDENING_LDFLAGS])
])
AX_CHECK_LINK_FLAG([-fcf-protection], [
- AX_APPEND_FLAG([-fcf-protection], [SSP_CFLAGS])
- AX_APPEND_FLAG([-Wc,-fcf-protection], [SSP_LDFLAGS])
+ AX_APPEND_FLAG([-fcf-protection], [HARDENING_CFLAGS])
+ AX_APPEND_FLAG([-Wc,-fcf-protection], [HARDENING_LDFLAGS])
])
AX_CHECK_LINK_FLAG([-Wl,-z,relro], [AX_APPEND_FLAG([-Wl,-z,relro], [LDFLAGS])])
AX_CHECK_LINK_FLAG([-Wl,-z,now], [AX_APPEND_FLAG([-Wl,-z,now], [LDFLAGS])])