summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTodd C. Miller <Todd.Miller@sudo.ws>2022-06-27 12:48:03 -0600
committerTodd C. Miller <Todd.Miller@sudo.ws>2022-06-27 12:48:03 -0600
commit83f8f9e9278b346cdc03036ae8edbd3ed3c938e8 (patch)
treee879ab0cd6ca37466d64f6da4a40928e40e5a812 /configure.ac
parent50f18694b2b4d7553020ca649148b467a6a6ea38 (diff)
downloadsudo-83f8f9e9278b346cdc03036ae8edbd3ed3c938e8.tar.gz
Make sudo pass -Wmissing-prototypes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9f845eddd..3bd5437ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4995,7 +4995,7 @@ if test -n "$GCC"; then
dnl
dnl Default warnings for development use.
dnl
- CFLAGS="${CFLAGS} -Wall -Wsign-compare -Wpointer-arith -Wno-unknown-pragmas"
+ CFLAGS="${CFLAGS} -Wall -Wsign-compare -Wpointer-arith -Wno-unknown-pragmas -Wmissing-prototypes"
AX_CHECK_COMPILE_FLAG([-Wshadow], [CFLAGS="$CFLAGS -Wshadow"])
dnl
dnl The fallthrough attribute is supported by gcc 7.0 and clang 10.