summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTodd C. Miller <Todd.Miller@sudo.ws>2022-11-11 09:37:49 -0700
committerTodd C. Miller <Todd.Miller@sudo.ws>2022-11-11 09:37:49 -0700
commita129e859fb374145ae6027497f24ea604211bd3b (patch)
tree47dcea4e6e49f2474e749531326584be683ed9fb /configure.ac
parent7c1e608dd5cefc2dbb5a22d7bf5cc11f8f143fb5 (diff)
downloadsudo-a129e859fb374145ae6027497f24ea604211bd3b.tar.gz
Remove checks for random() and lrand48(), they are no longer used.
Also remove duplicate checks for arc4random() and getentropy().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 978d4839d..b8486626f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2965,10 +2965,6 @@ case "$host_os" in
esac
# If any of the mktemp family are missing we use our own.
if test X"$sudo_mktemp" = X"yes"; then
- AC_CHECK_FUNCS([arc4random random lrand48], [break])
- if test X"$ac_cv_func_arc4random" != X"yes"; then
- AC_CHECK_FUNCS([getentropy])
- fi
AC_LIBOBJ(mktemp)
SUDO_APPEND_COMPAT_EXP(sudo_mkdtemp sudo_mkdtempat sudo_mkostempsat sudo_mkstemp sudo_mkstemps)
COMPAT_TEST_PROGS="${COMPAT_TEST_PROGS}${COMPAT_TEST_PROGS+ }mktemp_test"