summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTodd C. Miller <Todd.Miller@sudo.ws>2022-06-03 09:43:34 -0600
committerTodd C. Miller <Todd.Miller@sudo.ws>2022-06-03 09:43:34 -0600
commitaf8ceedcfc3a483adeb8757fa39ad8eb787a071d (patch)
treea9955e702cdec5b60c4e7b347c91272b27cf6cf8 /configure.ac
parent5c9ae15e404a5c89dbb408a6a82866879c4c7079 (diff)
downloadsudo-af8ceedcfc3a483adeb8757fa39ad8eb787a071d.tar.gz
Avoid using vfork(2) in the DSO system(3) wrapper.
Traditional vfork(2) semantics make it unsafe for use for more than just vfork(2) + execve(2).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6aa4a2b8b..31ab3c3c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2605,7 +2605,7 @@ dnl Function checks
dnl
AC_FUNC_GETGROUPS
AC_FUNC_FSEEKO
-AC_CHECK_FUNCS_ONCE([fexecve fmemopen killpg nl_langinfo faccessat wordexp getauxval strtoull vfork])
+AC_CHECK_FUNCS_ONCE([fexecve fmemopen killpg nl_langinfo faccessat wordexp getauxval strtoull])
AC_CHECK_FUNCS([execvpe], [SUDO_APPEND_INTERCEPT_EXP(execvpe)])
AC_CHECK_FUNCS([pread], [
# pread/pwrite on 32-bit HP-UX 11.x may not support large files