summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTodd C. Miller <Todd.Miller@sudo.ws>2022-06-28 16:33:15 -0600
committerTodd C. Miller <Todd.Miller@sudo.ws>2022-06-28 16:33:15 -0600
commitb0f4428dd068c2d9a7fb4d5a7073efa2c182b7d6 (patch)
tree7b62f84248101456404439697697eda0dfc9b73c /configure.ac
parent1354b8515217f9e0f925631bf6fe2d399ccc63fd (diff)
downloadsudo-b0f4428dd068c2d9a7fb4d5a7073efa2c182b7d6.tar.gz
Make sudo pass -Wwrite-strings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f903498e0..676166bf5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4995,7 +4995,7 @@ if test -n "$GCC"; then
dnl
dnl Default warnings for development use.
dnl
- CFLAGS="${CFLAGS} -Wall -Wsign-compare -Wpointer-arith -Wno-unknown-pragmas -Wmissing-prototypes"
+ CFLAGS="${CFLAGS} -Wall -Wsign-compare -Wpointer-arith -Wno-unknown-pragmas -Wmissing-prototypes -Wwrite-strings"
AX_CHECK_COMPILE_FLAG([-Wshadow], [CFLAGS="$CFLAGS -Wshadow"])
dnl
dnl The fallthrough attribute is supported by gcc 7.0 and clang 10.