summaryrefslogtreecommitdiff
path: root/Source/Makefile.am
diff options
context:
space:
mode:
authorSimon Marchetto <simon.marchetto@scilab-enterprises.com>2014-06-06 16:33:16 +0200
committerSimon Marchetto <simon.marchetto@scilab-enterprises.com>2014-06-06 16:33:16 +0200
commit07b06a408962f129a1c8b54dfc33a7e7c672fc72 (patch)
tree961950048a0fd8de33f234bfb34dc3d34818bc57 /Source/Makefile.am
parent9dda9285eabfcc8c4b4ae4df339ba3fe23224f09 (diff)
parentef4cb2f57465025203961a484fd8f7a0a8c9faa7 (diff)
downloadswig-07b06a408962f129a1c8b54dfc33a7e7c672fc72.tar.gz
Merge branch 'master' into gsoc2012-scilab
Conflicts: .gitignore .travis.yml COPYRIGHT Examples/Makefile.in Examples/test-suite/constructor_copy.i Makefile.in configure.ac
Diffstat (limited to 'Source/Makefile.am')
-rw-r--r--Source/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Source/Makefile.am b/Source/Makefile.am
index f0b53411a..66a7addfd 100644
--- a/Source/Makefile.am
+++ b/Source/Makefile.am
@@ -48,12 +48,14 @@ eswig_SOURCES = CParse/cscanner.c \
Modules/go.cxx \
Modules/guile.cxx \
Modules/java.cxx \
+ Modules/javascript.cxx \
Modules/lang.cxx \
Modules/lua.cxx \
Modules/main.cxx \
Modules/modula3.cxx \
Modules/module.cxx \
Modules/mzscheme.cxx \
+ Modules/nested.cxx \
Modules/ocaml.cxx \
Modules/octave.cxx \
Modules/overload.cxx \
@@ -76,6 +78,7 @@ eswig_SOURCES = CParse/cscanner.c \
Swig/cwrap.c \
Swig/deprecate.c \
Swig/error.c \
+ Swig/extend.c \
Swig/fragment.c \
Swig/getopt.c \
Swig/include.c \
@@ -89,7 +92,7 @@ eswig_SOURCES = CParse/cscanner.c \
Swig/typeobj.c \
Swig/typemap.c \
Swig/typesys.c \
- Swig/wrapfunc.c
+ Swig/wrapfunc.c
bin_PROGRAMS = eswig
eswig_LDADD = @SWIGLIBS@
@@ -98,7 +101,7 @@ eswig_LDADD = @SWIGLIBS@
CXXLINK = $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
# The executable is copied to the root directory for installation and running the test-suite.
-# This occurs on each invocation of make and is a step towards providing support for multiple
+# This occurs on each invocation of make and is a step towards providing support for multiple
# build directories.
all-local: eswig@EXEEXT@
cp -f $(top_builddir)/Source/eswig@EXEEXT@ $(top_builddir)/swig@EXEEXT@
@@ -117,7 +120,7 @@ distclean-local:
# swig executable as a way of checking before and after the 'beautifying'.
# Single files can be beautified with the beautify-file target, eg: 'make beautify-file INDENTFILE=chosenfile.c'
-SWIGTYPEDEFS=-T bool -T File -T DohObjInfo -T Parm -T Language -T List -T Typetab -T ModuleFactory -T ErrorMessageFormat -T Symtab -T Hash -T String -T DohBase -T Node -T String_or_char -T SwigType -T Dispatcher -T Wrapper -T DohStringMethods -T DohFileMethods -T DohListMethods -T DohHashMethods -T DOH -T DohIterator -T ParmList -T FILE -T HashNode -T DOHString_or_char
+SWIGTYPEDEFS=-T bool -T File -T DohObjInfo -T Parm -T Language -T List -T Typetab -T ModuleFactory -T ErrorMessageFormat -T Symtab -T Hash -T Scanner -T String -T DohBase -T Node -T String_or_char -T SwigType -T Dispatcher -T Wrapper -T DohStringMethods -T DohFileMethods -T DohListMethods -T DohHashMethods -T DOH -T DohIterator -T ParmList -T FILE -T HashNode -T DOHObj_or_char -T DOHFile -T DOHString -T DOHString_or_char -T UpcallData
INDENTBAKSDIR=../IndentBaks
beautify:
@@ -144,4 +147,3 @@ beautify-file:
indent -kr --honour-newlines --line-length160 --indent-level2 --braces-on-func-def-line --leave-optional-blank-lines $(SWIGTYPEDEFS) $(INDENTFILE) -o $(INDENTFILE).tmp;
cat $(INDENTFILE).tmp | sed -e 's/const const /const /' > $(INDENTFILE);
rm $(INDENTFILE).tmp;
-