summaryrefslogtreecommitdiff
path: root/Source/Makefile.am
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2019-02-03 21:59:48 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2019-02-04 18:46:16 +0000
commit9defd8e0330ebd491b2102bb7dc6d6b43715c712 (patch)
treec96b550569834ec297dd91ac17869cb45ed17e3f /Source/Makefile.am
parentb50e5fac8e1d76e8810c552f533a43f67ff57837 (diff)
downloadswig-9defd8e0330ebd491b2102bb7dc6d6b43715c712.tar.gz
Add support for differentiating target language statuses
Three status: Disabled, Experimental and Supported. Any target language classified as 'Experimental' will issue new warning 524 SWIGWARN_LANG_EXPERIMENTAL. Any target language classified as 'Disabled' will error out. Languages will be classified in forthcoming commits. Issue #1437
Diffstat (limited to 'Source/Makefile.am')
-rw-r--r--Source/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Source/Makefile.am b/Source/Makefile.am
index 74aff08c9..8b76694e8 100644
--- a/Source/Makefile.am
+++ b/Source/Makefile.am
@@ -65,9 +65,8 @@ eswig_SOURCES = CParse/cscanner.c \
Modules/lua.cxx \
Modules/main.cxx \
Modules/modula3.cxx \
- Modules/module.cxx \
Modules/mzscheme.cxx \
- Modules/nested.cxx \
+ Modules/nested.cxx \
Modules/ocaml.cxx \
Modules/octave.cxx \
Modules/overload.cxx \
@@ -132,7 +131,7 @@ distclean-local:
# swig executable as a way of checking before and after the 'beautifying'.
# Single files can be beautified with the beautify-file target, eg: 'make beautify-file INDENTFILE=chosenfile.c'
-SWIGTYPEDEFS=-T bool -T File -T DohObjInfo -T Parm -T Language -T List -T Typetab -T ModuleFactory -T ErrorMessageFormat -T Symtab -T Hash -T Scanner -T String -T DohBase -T Node -T String_or_char -T SwigType -T Dispatcher -T Wrapper -T DohStringMethods -T DohFileMethods -T DohListMethods -T DohHashMethods -T DOH -T DohIterator -T ParmList -T FILE -T HashNode -T DOHObj_or_char -T DOHFile -T DOHString -T DOHString_or_char -T UpcallData
+SWIGTYPEDEFS=-T bool -T File -T DohObjInfo -T Parm -T Language -T List -T TargetLanguageModule -T Typetab -T ModuleFactory -T ErrorMessageFormat -T Symtab -T Hash -T Scanner -T String -T DohBase -T Node -T String_or_char -T SwigType -T Dispatcher -T Wrapper -T DohStringMethods -T DohFileMethods -T DohListMethods -T DohHashMethods -T DOH -T DohIterator -T ParmList -T FILE -T HashNode -T DOHObj_or_char -T DOHFile -T DOHString -T DOHString_or_char -T UpcallData
INDENTBAKSDIR=../IndentBaks
beautify: