summaryrefslogtreecommitdiff
path: root/Source/Makefile.am
diff options
context:
space:
mode:
authorOliver Buchtala <oliver.buchtala@googlemail.com>2014-03-05 01:09:26 +0100
committerOliver Buchtala <oliver.buchtala@googlemail.com>2014-03-05 01:09:26 +0100
commita234542543088140e4dd925b0060a93960db9eee (patch)
tree952d2818d50027d150b5388dc121e99ef95316e5 /Source/Makefile.am
parent8c05fe37afcbcd6a2fc2a7d8bbe028e6d8f59239 (diff)
parentc99417ab136ed643c437065c88368b67b4e77fa3 (diff)
downloadswig-a234542543088140e4dd925b0060a93960db9eee.tar.gz
Merge branch 'master' into tmp
Conflicts: .travis.yml Examples/Makefile.in Examples/test-suite/director_nspace.i Examples/test-suite/nspace.i Examples/test-suite/nspace_extend.i Source/Modules/lang.cxx configure.ac
Diffstat (limited to 'Source/Makefile.am')
-rw-r--r--Source/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Source/Makefile.am b/Source/Makefile.am
index 9cd55c7dc..4dbede635 100644
--- a/Source/Makefile.am
+++ b/Source/Makefile.am
@@ -55,6 +55,7 @@ eswig_SOURCES = CParse/cscanner.c \
Modules/modula3.cxx \
Modules/module.cxx \
Modules/mzscheme.cxx \
+ Modules/nested.cxx \
Modules/ocaml.cxx \
Modules/octave.cxx \
Modules/overload.cxx \
@@ -117,7 +118,7 @@ distclean-local:
# swig executable as a way of checking before and after the 'beautifying'.
# Single files can be beautified with the beautify-file target, eg: 'make beautify-file INDENTFILE=chosenfile.c'
-SWIGTYPEDEFS=-T bool -T File -T DohObjInfo -T Parm -T Language -T List -T Typetab -T ModuleFactory -T ErrorMessageFormat -T Symtab -T Hash -T String -T DohBase -T Node -T String_or_char -T SwigType -T Dispatcher -T Wrapper -T DohStringMethods -T DohFileMethods -T DohListMethods -T DohHashMethods -T DOH -T DohIterator -T ParmList -T FILE -T HashNode -T DOHString_or_char
+SWIGTYPEDEFS=-T bool -T File -T DohObjInfo -T Parm -T Language -T List -T Typetab -T ModuleFactory -T ErrorMessageFormat -T Symtab -T Hash -T Scanner -T String -T DohBase -T Node -T String_or_char -T SwigType -T Dispatcher -T Wrapper -T DohStringMethods -T DohFileMethods -T DohListMethods -T DohHashMethods -T DOH -T DohIterator -T ParmList -T FILE -T HashNode -T DOHObj_or_char -T DOHFile -T DOHString -T DOHString_or_char -T UpcallData
INDENTBAKSDIR=../IndentBaks
beautify:
@@ -141,8 +142,6 @@ beautify-file:
test -n "$(INDENTFILE)" || (echo INDENTFILE not defined && exit 1;)
test -e $(INDENTFILE) || (echo File does not exist: $(INDENTFILE) && exit 1;)
cp $(INDENTFILE) $(INDENTBAKSDIR)/$(INDENTFILE);
- unix2dos $(INDENTFILE)
- dos2unix $(INDENTFILE)
indent -kr --honour-newlines --line-length160 --indent-level2 --braces-on-func-def-line --leave-optional-blank-lines $(SWIGTYPEDEFS) $(INDENTFILE) -o $(INDENTFILE).tmp;
cat $(INDENTFILE).tmp | sed -e 's/const const /const /' > $(INDENTFILE);
rm $(INDENTFILE).tmp;