summaryrefslogtreecommitdiff
path: root/Source/Makefile.am
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2018-05-26 12:52:52 +0100
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2018-05-26 12:52:52 +0100
commitac85784a76066870b47ea624ccd155098ec0c4ee (patch)
treee370581e6aaec0836cb1e40300205ee83e7ca882 /Source/Makefile.am
parent0ae73a67ff4ceed3a70991fbd05c7f93305f31be (diff)
downloadswig-ac85784a76066870b47ea624ccd155098ec0c4ee.tar.gz
Doxygen source rename
Source/DoxygenTranslator/src directory is renamed Source/Doxygen Renamed files in this directory to short names using lowercase as is the convention for the rest of the SWIG source. C++ extension is also .cxx like other SWIG source code. I used doxy as the prefix for most file renames because without this Doxygen/parser.* would be easily confused with CParse/parser.* so Doxygen/doxyparser.* is renamed from DoxygenTranslator/src/DoxygenParser.*
Diffstat (limited to 'Source/Makefile.am')
-rw-r--r--Source/Makefile.am24
1 files changed, 12 insertions, 12 deletions
diff --git a/Source/Makefile.am b/Source/Makefile.am
index b1d6359b0..df3d4b75f 100644
--- a/Source/Makefile.am
+++ b/Source/Makefile.am
@@ -34,6 +34,16 @@ eswig_SOURCES = CParse/cscanner.c \
DOH/memory.c \
DOH/string.c \
DOH/void.c \
+ Doxygen/doxyentity.cxx \
+ Doxygen/doxyentity.h \
+ Doxygen/doxyparser.cxx \
+ Doxygen/doxyparser.h \
+ Doxygen/doxytranslator.cxx \
+ Doxygen/doxytranslator.h \
+ Doxygen/javadoc.cxx \
+ Doxygen/javadoc.h \
+ Doxygen/pydoc.cxx \
+ Doxygen/pydoc.h \
Modules/allegrocl.cxx \
Modules/allocate.cxx \
Modules/browser.cxx \
@@ -91,20 +101,10 @@ eswig_SOURCES = CParse/cscanner.c \
Swig/stype.c \
Swig/symbol.c \
Swig/tree.c \
- Swig/typeobj.c \
Swig/typemap.c \
+ Swig/typeobj.c \
Swig/typesys.c \
- Swig/wrapfunc.c \
- DoxygenTranslator/src/DoxygenEntity.h\
- DoxygenTranslator/src/DoxygenEntity.cpp\
- DoxygenTranslator/src/DoxygenParser.h\
- DoxygenTranslator/src/DoxygenParser.cpp\
- DoxygenTranslator/src/DoxygenTranslator.h\
- DoxygenTranslator/src/DoxygenTranslator.cpp\
- DoxygenTranslator/src/JavaDocConverter.h\
- DoxygenTranslator/src/JavaDocConverter.cpp\
- DoxygenTranslator/src/PyDocConverter.h\
- DoxygenTranslator/src/PyDocConverter.cpp
+ Swig/wrapfunc.c
bin_PROGRAMS = eswig
eswig_LDADD = @SWIGLIBS@