summaryrefslogtreecommitdiff
path: root/Source/Makefile.am
diff options
context:
space:
mode:
authorWilliam S Fulton <wsf@fultondesigns.co.uk>2012-04-27 18:55:37 +0000
committerWilliam S Fulton <wsf@fultondesigns.co.uk>2012-04-27 18:55:37 +0000
commitaf1c6ac3c326d0ee9c5cc526e5537918d7e309f8 (patch)
treecf7c9e3af6244b8126c978c301b29159aaee9de4 /Source/Makefile.am
parent02fbe37ae6147b64e21c153b45a9a09313668438 (diff)
parente464aa021b456425cd6c568cb7407fc0349919a5 (diff)
downloadswig-af1c6ac3c326d0ee9c5cc526e5537918d7e309f8.tar.gz
Merge trunk (up to just after swig 2.0.5 release - rev 13009) to gsoc2008-cherylfoil
git-svn-id: https://swig.svn.sourceforge.net/svnroot/swig/branches/gsoc2008-cherylfoil@13017 626c5289-ae23-0410-ae9c-e8d60b6d4f22
Diffstat (limited to 'Source/Makefile.am')
-rw-r--r--Source/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Source/Makefile.am b/Source/Makefile.am
index bfa6b3413..6a5cb91b0 100644
--- a/Source/Makefile.am
+++ b/Source/Makefile.am
@@ -8,7 +8,7 @@ BUILD_SOURCE_DIR=$(top_builddir)/Source
SWIG_CXX_DEFS = @SWILL@
-AM_CFLAGS = -I$(BUILD_SOURCE_DIR)/Include \
+AM_CPPFLAGS = -I$(BUILD_SOURCE_DIR)/Include \
-I$(BUILD_SOURCE_DIR)/CParse \
-I$(SOURCE_DIR)/Include \
-I$(SOURCE_DIR)/DOH \
@@ -17,8 +17,7 @@ AM_CFLAGS = -I$(BUILD_SOURCE_DIR)/Include \
-I$(SOURCE_DIR)/Swig \
-I$(SOURCE_DIR)/Modules
-AM_CXXFLAGS = $(AM_CFLAGS) \
- $(SWIG_CXX_DEFS)
+AM_CXXFLAGS = $(SWIG_CXX_DEFS)
AM_YFLAGS = -d
@@ -43,8 +42,10 @@ eswig_SOURCES = CParse/cscanner.c \
Modules/clisp.cxx \
Modules/contract.cxx \
Modules/csharp.cxx \
+ Modules/d.cxx \
Modules/directors.cxx \
Modules/emit.cxx \
+ Modules/go.cxx \
Modules/guile.cxx \
Modules/java.cxx \
Modules/lang.cxx \
@@ -87,7 +88,6 @@ eswig_SOURCES = CParse/cscanner.c \
Swig/typeobj.c \
Swig/typemap.c \
Swig/typesys.c \
- Swig/warn.c \
Swig/wrapfunc.c \
DoxygenTranslator/src/DoxygenEntity.h\
DoxygenTranslator/src/DoxygenEntity.cpp\
@@ -120,6 +120,9 @@ clean-local:
rm -f $(top_builddir)/swig@EXEEXT@
rm -f core @EXTRA_CLEAN@
+distclean-local:
+ rm -f $(top_builddir)/Source/Include/swigconfig.h
+ rm -f $(top_builddir)/Source/Include/stamp-h1
# Beautify the code.
# Note that this works well on C code, but does some odd joining of lines for C++ code.
@@ -127,7 +130,7 @@ clean-local:
# swig executable as a way of checking before and after the 'beautifying'.
# Single files can be beautified with the beautify-file target, eg: 'make beautify-file INDENTFILE=chosenfile.c'
-SWIGTYPEDEFS=-T File -T DohObjInfo -T Parm -T Language -T List -T Typetab -T ModuleFactory -T ErrorMessageFormat -T Symtab -T Hash -T String -T DohBase -T Node -T String_or_char -T SwigType -T Dispatcher -T Wrapper -T DohStringMethods -T DohFileMethods -T DohListMethods -T DohHashMethods -T DOH -T DohIterator -T ParmList -T FILE -T HashNode -T DOHString_or_char
+SWIGTYPEDEFS=-T bool -T File -T DohObjInfo -T Parm -T Language -T List -T Typetab -T ModuleFactory -T ErrorMessageFormat -T Symtab -T Hash -T String -T DohBase -T Node -T String_or_char -T SwigType -T Dispatcher -T Wrapper -T DohStringMethods -T DohFileMethods -T DohListMethods -T DohHashMethods -T DOH -T DohIterator -T ParmList -T FILE -T HashNode -T DOHString_or_char
INDENTBAKSDIR=../IndentBaks
beautify: