summaryrefslogtreecommitdiff
path: root/Source/Makefile.am
diff options
context:
space:
mode:
authorOlly Betts <olly@survex.com>2022-04-01 11:24:15 +1300
committerOlly Betts <olly@survex.com>2022-04-03 08:56:07 +1200
commitef3f25ab1c03d37802d9c228a5dab2946b549a3b (patch)
treeeb698fa529deba7032837b3100bcb4abdd1ce9fa /Source/Makefile.am
parente4c972c328f7edd11570abeb6104775711e50db5 (diff)
downloadswig-ef3f25ab1c03d37802d9c228a5dab2946b549a3b.tar.gz
Remove -browse command line option
This option was undocumented. If used it quietly did nothing unless you'd installed the SWILL library before building SWIG, but SWILL is no longer maintained and hasn't seen a release since 2008-04-10. It's clear nobody has used this functionality for some time as the code to support it in SWIG isn't actually valid ISO C++: Modules/browser.cxx: In member function ‘void Browser::show_attributes(Node*)’: Modules/browser.cxx:57:23: warning: ISO C++ forbids converting a string constant to ‘char*’ [-Wwrite-strings] 57 | char *trunc = ""; | ^~ Modules/browser.cxx:61:21: warning: ISO C++ forbids converting a string constant to ‘char*’ [-Wwrite-strings] 61 | trunc = "..."; | ^~~~~ Closes #2251
Diffstat (limited to 'Source/Makefile.am')
-rw-r--r--Source/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/Source/Makefile.am b/Source/Makefile.am
index 5cfb88839..095c5d4ea 100644
--- a/Source/Makefile.am
+++ b/Source/Makefile.am
@@ -6,8 +6,6 @@ AUTOMAKE_OPTIONS = foreign nostdinc subdir-objects 1.7.2
SOURCE_DIR=$(top_srcdir)/Source
BUILD_SOURCE_DIR=$(top_builddir)/Source
-SWIG_CXX_DEFS = @SWILL@
-
AM_CPPFLAGS = -I$(BUILD_SOURCE_DIR)/Include \
-I$(BUILD_SOURCE_DIR)/CParse \
-I$(SOURCE_DIR)/Include \
@@ -18,7 +16,7 @@ AM_CPPFLAGS = -I$(BUILD_SOURCE_DIR)/Include \
-I$(SOURCE_DIR)/Swig \
-I$(SOURCE_DIR)/Modules
-AM_CXXFLAGS = $(SWIG_CXX_DEFS)
+AM_CXXFLAGS =
AM_YFLAGS = -d
@@ -46,7 +44,6 @@ eswig_SOURCES = CParse/cscanner.c \
Doxygen/pydoc.cxx \
Doxygen/pydoc.h \
Modules/allocate.cxx \
- Modules/browser.cxx \
Modules/contract.cxx \
Modules/csharp.cxx \
Modules/d.cxx \
@@ -98,7 +95,6 @@ eswig_SOURCES = CParse/cscanner.c \
Swig/wrapfunc.c
bin_PROGRAMS = eswig
-eswig_LDADD = @SWIGLIBS@
# Override the link stage to avoid using Libtool
CXXLINK = $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@