summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOlly Betts <olly@survex.com>2021-03-17 12:45:17 +1300
committerOlly Betts <olly@survex.com>2021-03-19 19:30:27 +1300
commit3584c7d49cb598ce79d5e285d6c17b2dedfe3ecb (patch)
treede791de9522ea7676b526a3a09fe49e08b2ed76d /configure.ac
parent3b822ee60c9195283f461120252fdf34b7328050 (diff)
downloadswig-3584c7d49cb598ce79d5e285d6c17b2dedfe3ecb.tar.gz
Add initial support for PHP8
Testcase director_overload2 is failing, but the rest of the testsuite passes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 7d5824a06..1894001c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2021,7 +2021,7 @@ AC_SUBST(RUBYSO)
AC_SUBST(RUBYDYNAMICLINKING)
#-------------------------------------------------------------------------
-# Look for PHP7
+# Look for PHP
#-------------------------------------------------------------------------
PHPBIN=
@@ -2035,7 +2035,7 @@ if test x"${PHPBIN}" = xno; then
PHP=
else
if test "x$PHPBIN" = xyes; then
- AC_CHECK_PROGS(PHP, [php7.4 php7.3 php7.2 php7.1 php7.0 php])
+ AC_CHECK_PROGS(PHP, [php8.0 php7.4 php7.3 php7.2 php7.1 php7.0 php])
else
PHP=$PHPBIN
fi
@@ -2046,12 +2046,14 @@ else
case $PHP in
*7.*)
PHPCONFIG=`echo "$PHP"|sed 's/7\...*$/-config&/'` ;;
+ *8.*)
+ PHPCONFIG=`echo "$PHP"|sed 's/8\...*$/-config&/'` ;;
*)
PHPCONFIG=$PHP-config ;;
esac
php_version=`$PHPCONFIG --version 2>/dev/null`
case $php_version in
- 7.*)
+ 7.*|8.*)
PHPINC=`$PHPCONFIG --includes 2>/dev/null`
if test -n "$PHPINC"; then
AC_MSG_RESULT($PHPINC)
@@ -2062,7 +2064,7 @@ else
"")
AC_MSG_RESULT([could not find $PHPCONFIG or obtain PHP version from it]) ;;
*)
- AC_MSG_RESULT([found PHP $php_version - not PHP 7]) ;;
+ AC_MSG_RESULT([found PHP $php_version - not PHP 7 or 8]) ;;
esac
fi
fi