summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorstekloff <stekloff>2005-04-06 20:57:01 +0000
committerstekloff <stekloff>2005-04-06 20:57:01 +0000
commitdd8c511d725f816bc64592028ff178616fcde607 (patch)
tree55250e02ac67ceeb3c2bac3b1e29a78c22be1ac2 /configure.ac
parent855a337e54321d9aa2b97c38ffa4787d3105257c (diff)
downloadsysfsutils-dd8c511d725f816bc64592028ff178616fcde607.tar.gz
Merging tag sysfsutils-1_3_0 with main trunk.HEADoriginmaster
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..d17a20a
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,36 @@
+# Process this file with autoconf to produce a configure script.
+AC_INIT(sysfsutils, 1.2.0, linux-diag-devel@lists.sourceforge.net)
+AM_INIT_AUTOMAKE
+AC_CONFIG_SRCDIR([config.h.in])
+AM_CONFIG_HEADER([config.h])
+AC_PROG_LIBTOOL
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_RANLIB
+AC_PROG_AWK
+
+# Checks for header files.
+AC_HEADER_DIRENT
+AC_HEADER_STDC
+AC_CHECK_HEADERS([fcntl.h malloc.h mntent.h stdlib.h string.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_C_INLINE
+AC_TYPE_SIZE_T
+
+# Checks for library functions.
+AC_FUNC_LSTAT
+AC_FUNC_MALLOC
+AC_FUNC_STAT
+AC_CHECK_FUNCS([bzero getmntent isascii memset strchr strerror strrchr strstr strtol])
+
+AC_CONFIG_FILES([Makefile
+ cmd/Makefile
+ lib/Makefile
+ test/Makefile])
+AC_OUTPUT