summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorstekloff <stekloff>2005-04-06 20:57:01 +0000
committerstekloff <stekloff>2005-04-06 20:57:01 +0000
commitdd8c511d725f816bc64592028ff178616fcde607 (patch)
tree55250e02ac67ceeb3c2bac3b1e29a78c22be1ac2 /lib/Makefile.am
parent855a337e54321d9aa2b97c38ffa4787d3105257c (diff)
downloadsysfsutils-dd8c511d725f816bc64592028ff178616fcde607.tar.gz
Merging tag sysfsutils-1_3_0 with main trunk.HEADoriginmaster
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..2a11ba9
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,6 @@
+lib_LTLIBRARIES = libsysfs.la
+libsysfs_la_SOURCES = sysfs_utils.c sysfs_dir.c sysfs_bus.c sysfs_class.c \
+ sysfs_device.c sysfs_driver.c sysfs.h dlist.c
+INCLUDES = -I../include
+libsysfs_la_LDFLAGS = -version-info 1:2:0
+libsysfs_la_CFLAGS = -Wall -W -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls