summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-03-20 22:56:25 +0100
committerLennart Poettering <lennart@poettering.net>2013-03-20 23:00:10 +0100
commit89ffcd2ad5bf87866314e96c4179ba622851cd6e (patch)
treeb6415892e9160fbf11a95244617d69992d024026 /Makefile.am
parentfbfa72b0a1276366d50dce223c06efe9db9d6585 (diff)
downloadsystemd-89ffcd2ad5bf87866314e96c4179ba622851cd6e.tar.gz
bus: hook up client with socket communication
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 27 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c94c192ce3..d8e9b16be0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1654,12 +1654,19 @@ libsystemd_bus_la_SOURCES = \
src/libsystemd-bus/bus-type.c \
src/libsystemd-bus/bus-type.h
+libsystemd_bus_la_LIBADD = \
+ libsystemd-id128-internal.la
+
noinst_LTLIBRARIES += \
libsystemd-bus.la
noinst_tests += \
test-bus-marshal \
- test-bus-signature
+ test-bus-signature \
+ test-bus-chat
+
+noinst_PROGRAMS += \
+ busctl
test_bus_marshal_SOURCES = \
src/libsystemd-bus/test-bus-marshal.c
@@ -1682,6 +1689,25 @@ test_bus_signature_LDADD = \
libsystemd-shared.la \
libsystemd-bus.la
+test_bus_chat_SOURCES = \
+ src/libsystemd-bus/test-bus-chat.c
+
+test_bus_chat_CFLAGS = \
+ $(AM_CFLAGS) \
+ -pthread
+
+test_bus_chat_LDADD = \
+ libsystemd-shared.la \
+ libsystemd-bus.la \
+ libsystemd-id128-internal.la
+
+busctl_SOURCES = \
+ src/libsystemd-bus/busctl.c
+
+busctl_LDADD = \
+ libsystemd-shared.la \
+ libsystemd-bus.la
+
# ------------------------------------------------------------------------------
if ENABLE_GTK_DOC
SUBDIRS += \