summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2015-10-03 18:41:02 +0200
committerTom Gundersen <teg@jklm.no>2015-10-05 17:33:58 +0200
commita245d90a898c2e1a77258aeb4b8a189ec771e804 (patch)
treea3ff6ba65085a57923201e61e4aba8c8174d69ee /Makefile.am
parentf4e5a03ed7d62e21b5533a7e1124d610bd0a81a4 (diff)
downloadsystemd-a245d90a898c2e1a77258aeb4b8a189ec771e804.tar.gz
test: siphash24 - add regression test
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 30989bfe8e..685d2634cd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1396,6 +1396,7 @@ tests += \
test-path \
test-path-util \
test-strxcpyx \
+ test-siphash24 \
test-unit-name \
test-unit-file \
test-utf8 \
@@ -2010,6 +2011,12 @@ test_execute_CFLAGS = \
test_execute_LDADD = \
libcore.la
+test_siphash24_SOURCES = \
+ src/test/test-siphash24.c
+
+test_siphash24_LDADD = \
+ libshared.la
+
test_strxcpyx_SOURCES = \
src/test/test-strxcpyx.c