summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-07-18 21:44:58 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-07-18 21:44:58 -0400
commite091457e822ff35ff7b1d3b3a1f91c2ee6249e5a (patch)
tree4533f61638536e73ec697c1ccb425d7a96edd31d /Makefile.am
parente7e9b6bb0b0bc5b1eb256a44f8afec6b634f26ef (diff)
downloadsystemd-e091457e822ff35ff7b1d3b3a1f91c2ee6249e5a.tar.gz
Makefile.am: tweaks to python commands
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index f0482cfe72..15a38bd4ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2898,11 +2898,12 @@ test_unifont_LDADD = \
libsystemd-internal.la \
libsystemd-shared.la
-update-unifont:
- $(AM_V_GEN)cat $(top_srcdir)/src/libsystemd-terminal/unifont.hex | $(PYTHON) $(top_srcdir)/tools/compile-unifont.py >$(top_srcdir)/src/libsystemd-terminal/unifont-glyph-array.bin
- @echo "unifont-glyph-array.bin has been regenerated"
-
.PHONY: update-unifont
+update-unifont: tools/compile-unifont.py
+ $(AM_V_GEN)$(PYTHON) $< \
+ <$(top_srcdir)/src/libsystemd-terminal/unifont.hex \
+ >$(top_srcdir)/src/libsystemd-terminal/unifont-glyph-array.bin
+ @echo "unifont-glyph-array.bin has been regenerated"
# ------------------------------------------------------------------------------
if ENABLE_GTK_DOC