summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2016-06-26 17:43:37 +0200
committerMartin Pitt <martin.pitt@ubuntu.com>2016-06-26 17:43:37 +0200
commit4b930ded8391c7552820f8f162b4e6ceebf50ca4 (patch)
tree9d3a81fb3a9c6ee3ca4780df6f0514dd2ea17bbe /configure.ac
parent68ce459f2fadd3f8aa6e083b4823b37116394956 (diff)
downloadsystemd-4b930ded8391c7552820f8f162b4e6ceebf50ca4.tar.gz
catalog: make support URL to show in shipped catalog entries configurable (#3597)
Let's allow distros to change the support URL to expose in catalog entries by default. It doesn't make sense to direct end-users to the upstream project for common errors. This adds a --with-support-url= switch to configure, which allows overriding the default at build-time. Fixes: #2516
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1326eebc6a..dd5f51fd7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -551,6 +551,14 @@ AC_ARG_WITH([certificate-root],
AC_SUBST(CERTIFICATEROOT)
+AC_ARG_WITH([support-url],
+ AS_HELP_STRING([--with-support-url=URL],
+ [Specify the supoport URL to show in catalog entries included in systemd]),
+ [SUPPORT_URL="$withval"],
+ [SUPPORT_URL=http://lists.freedesktop.org/mailman/listinfo/systemd-devel])
+
+AC_SUBST(SUPPORT_URL)
+
# ------------------------------------------------------------------------------
have_xz=no
AC_ARG_ENABLE(xz, AS_HELP_STRING([--disable-xz], [Disable optional XZ support]))
@@ -1665,6 +1673,7 @@ AC_MSG_RESULT([
Maximum System UID: ${SYSTEM_UID_MAX}
Maximum System GID: ${SYSTEM_GID_MAX}
Certificate root: ${CERTIFICATEROOT}
+ Support URL: ${SUPPORT_URL}
CFLAGS: ${OUR_CFLAGS} ${CFLAGS}
CPPFLAGS: ${OUR_CPPFLAGS} ${CPPFLAGS}