summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUmut Tezduyar <umut@tezduyar.com>2013-03-14 14:58:40 +0100
committerKay Sievers <kay@vrfy.org>2013-03-25 18:40:38 +0100
commitd95fd3df5997b0dab8650d9427997d295d0975e3 (patch)
treeacd2477b766fc2e1b3e27728a3a9bc64c9c998f2 /configure.ac
parent80c39ad27f5e99b1f18bdacd2b27a05ddee6cca1 (diff)
downloadsystemd-d95fd3df5997b0dab8650d9427997d295d0975e3.tar.gz
build-sys: configurable debug shell tty path
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f1bf7582fd..d6e5a090bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -755,6 +755,15 @@ AS_IF([test "x$enable_keymap" = "xyes"], [
AM_CONDITIONAL([ENABLE_KEYMAP], [test "x$enable_keymap" = "xyes"])
# ------------------------------------------------------------------------------
+debugshell=/dev/tty9
+AC_ARG_WITH([debugshelltty],
+ [AS_HELP_STRING([--with-debugshelltty=PATH],
+ [Specify the tty device for debug shell])],
+ [debugshell="$withval"],
+ [])
+AC_SUBST(debugshell)
+
+# ------------------------------------------------------------------------------
have_manpages=no
AC_ARG_ENABLE(manpages, AS_HELP_STRING([--disable-manpages], [disable manpages]))
AS_IF([test "x$enable_manpages" != xno], [