summaryrefslogtreecommitdiff
path: root/hwdb.d/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-05-14 16:12:51 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-05-14 19:52:25 +0200
commit7c22f07cbd86b39e78990057687e5509fa299672 (patch)
treea60365cb0c086712e52d8bdb846025e7fe5e8f74 /hwdb.d/meson.build
parentf86887af6e355ae7232ca550b607f9024d727f93 (diff)
downloadsystemd-7c22f07cbd86b39e78990057687e5509fa299672.tar.gz
meson: revert the change to unquote commands in add_install_script
Old meson fails with: Element not a string: [<Holder: <ExternalProgram 'sh' -> ['/bin/sh']>>, '-c', 'test -n "$DESTDIR" || /bin/journalctl --update-catalog'] I'm doing it as a revert so that it's easy to undo the revert when we require newer meson. The effect is not so bad, maybe a dozen or so lines about finding 'sh'.
Diffstat (limited to 'hwdb.d/meson.build')
-rw-r--r--hwdb.d/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/hwdb.d/meson.build b/hwdb.d/meson.build
index f43bcbbea7..fd8c15a521 100644
--- a/hwdb.d/meson.build
+++ b/hwdb.d/meson.build
@@ -47,9 +47,10 @@ if conf.get('ENABLE_HWDB') == 1
install_dir : udevhwdbdir)
if install_sysconfdir
- meson.add_install_script(sh, '-c', mkdir_p.format(join_paths(sysconfdir, 'udev/hwdb.d')))
+ meson.add_install_script('sh', '-c',
+ mkdir_p.format(join_paths(sysconfdir, 'udev/hwdb.d')))
- meson.add_install_script(sh, '-c',
+ meson.add_install_script('sh', '-c',
'test -n "$DESTDIR" || @0@/systemd-hwdb update'.format(rootbindir))
endif