summaryrefslogtreecommitdiff
path: root/hwdb/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-27 21:13:08 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-05-02 16:29:11 -0400
commit2c201c2140f9a75f3698e988880f00f8d0492315 (patch)
tree28f9835b7720692a60dda9b88a598994a03b396c /hwdb/meson.build
parent829257d135c496bd5d2770036c449445f77e0abc (diff)
downloadsystemd-2c201c2140f9a75f3698e988880f00f8d0492315.tar.gz
meson: use booleans for conf.set and drop unecessary conditionals
Using conf.set() with a boolean argument does the right thing: either #ifdef or #undef. This means that conf.set can be used unconditionally. Previously I used '1' as the placeholder value, and that needs to be changed to 'true' for consistency (under meson 1 cannot be used in boolean context). All checks need to be adjusted.
Diffstat (limited to 'hwdb/meson.build')
-rw-r--r--hwdb/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/hwdb/meson.build b/hwdb/meson.build
index 68a23e0afe..1f018111ed 100644
--- a/hwdb/meson.build
+++ b/hwdb/meson.build
@@ -17,7 +17,7 @@ hwdb_files = files('''
70-touchpad.hwdb
'''.split())
-if conf.get('ENABLE_HWDB', 0) == 1
+if conf.get('ENABLE_HWDB', false)
install_data(hwdb_files,
install_dir : udevhwdbdir)