summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-27 21:13:08 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-05-02 16:29:11 -0400
commit2c201c2140f9a75f3698e988880f00f8d0492315 (patch)
tree28f9835b7720692a60dda9b88a598994a03b396c /man/meson.build
parent829257d135c496bd5d2770036c449445f77e0abc (diff)
downloadsystemd-2c201c2140f9a75f3698e988880f00f8d0492315.tar.gz
meson: use booleans for conf.set and drop unecessary conditionals
Using conf.set() with a boolean argument does the right thing: either #ifdef or #undef. This means that conf.set can be used unconditionally. Previously I used '1' as the placeholder value, and that needs to be changed to 'true' for consistency (under meson 1 cannot be used in boolean context). All checks need to be adjusted.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/man/meson.build b/man/meson.build
index 9cdb560c4c..6f7b1e8793 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -50,7 +50,7 @@ foreach tuple : manpages
mandirn = join_paths(get_option('mandir'), 'man' + section)
- if condition == '' or conf.get(condition, 0) == 1
+ if condition == '' or conf.get(condition, false)
p1 = custom_target(
man,
input : xml,