summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-17 19:25:00 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-23 21:47:29 -0400
commit37efbbd8211bd40e2d1f1732e27bd7d3ca504a12 (patch)
tree2f445eca4ba6baa5bb3f41b1af4f3680b6ddae17 /man/meson.build
parent0a76b0e8a2043936b6dd598a7a3f924bd683eec8 (diff)
downloadsystemd-37efbbd8211bd40e2d1f1732e27bd7d3ca504a12.tar.gz
meson: reindent all files with 8 spaces
The indentation for emacs'es meson-mode is added .dir-locals. All files are reindented automatically, using the lasest meson-mode from git. Indentation should now be fairly consistent.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build185
1 files changed, 91 insertions, 94 deletions
diff --git a/man/meson.build b/man/meson.build
index 9d8d1a9922..1c1dbd86b7 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -1,5 +1,3 @@
-# -*- mode: meson -*-
-
# This is lame, I know, but meson has no other include mechanism
subdir('rules')
@@ -14,123 +12,122 @@ want_man = want_man != 'false' and xsltproc.found()
want_html = want_html != 'false' and xsltproc.found()
xsltproc_flags = [
- '--nonet',
- '--xinclude',
- '--stringparam', 'man.output.quietly', '1',
- '--stringparam', 'funcsynopsis.style', 'ansi',
- '--stringparam', 'man.authors.section.enabled', '0',
- '--stringparam', 'man.copyright.section.enabled', '0',
- '--stringparam', 'systemd.version', '@0@'.format(meson.project_version()),
- '--path',
- '@0@:@1@'.format(meson.current_build_dir(), meson.current_source_dir())]
+ '--nonet',
+ '--xinclude',
+ '--stringparam', 'man.output.quietly', '1',
+ '--stringparam', 'funcsynopsis.style', 'ansi',
+ '--stringparam', 'man.authors.section.enabled', '0',
+ '--stringparam', 'man.copyright.section.enabled', '0',
+ '--stringparam', 'systemd.version', '@0@'.format(meson.project_version()),
+ '--path',
+ '@0@:@1@'.format(meson.current_build_dir(), meson.current_source_dir())]
custom_man_xsl = files('custom-man.xsl')
custom_html_xsl = files('custom-html.xsl')
+xslt_cmd = [xsltproc, '-o', '@OUTPUT0@'] + xsltproc_flags
custom_entities_ent = configure_file(
- input : 'custom-entities.ent.in',
- output : 'custom-entities.ent',
- configuration : conf)
+ input : 'custom-entities.ent.in',
+ output : 'custom-entities.ent',
+ configuration : conf)
man_pages = []
html_pages = []
source_xml_files = []
foreach tuple : manpages
- stem = tuple[0]
- section = tuple[1]
- aliases = tuple[2]
- condition = tuple[3]
-
- xml = stem + '.xml'
- html = stem + '.html'
- man = stem + '.' + section
-
- manaliases = []
- htmlaliases = []
- foreach alias : aliases
- manaliases += [alias + '.' + section]
- htmlaliases += [alias + '.html']
- endforeach
-
- mandirn = join_paths(get_option('mandir'), 'man' + section)
-
- have = condition == '' or conf.get(condition, 0) == 1
-
- if have
- p1 = custom_target(
- man,
- input : xml,
- output : [man] + manaliases,
- command : [xsltproc, '-o', '@OUTPUT0@'] + xsltproc_flags + [custom_man_xsl, '@INPUT@'],
- depend_files : custom_entities_ent,
- install : want_man,
- install_dir : mandirn)
- man_pages += [p1]
-
- p2 = custom_target(
- html,
- input : xml,
- output : [html] + htmlaliases,
- command : [xsltproc, '-o', '@OUTPUT0@'] + xsltproc_flags + [custom_html_xsl, '@INPUT@'],
- depend_files : custom_entities_ent,
- install : want_html,
- install_dir : join_paths(docdir, 'html'))
- html_pages += [p2]
-
- source_xml_files += files(tuple[0] + '.xml')
- else
- message('Skipping @0@.@1@ because @2@ is @3@'.format(stem, section, condition, have))
- endif
+ stem = tuple[0]
+ section = tuple[1]
+ aliases = tuple[2]
+ condition = tuple[3]
+
+ xml = stem + '.xml'
+ html = stem + '.html'
+ man = stem + '.' + section
+
+ manaliases = []
+ htmlaliases = []
+ foreach alias : aliases
+ manaliases += [alias + '.' + section]
+ htmlaliases += [alias + '.html']
+ endforeach
+
+ mandirn = join_paths(get_option('mandir'), 'man' + section)
+
+ if condition == '' or conf.get(condition, 0) == 1
+ p1 = custom_target(
+ man,
+ input : xml,
+ output : [man] + manaliases,
+ command : xslt_cmd + [custom_man_xsl, '@INPUT@'],
+ depend_files : custom_entities_ent,
+ install : want_man,
+ install_dir : mandirn)
+ man_pages += [p1]
+
+ p2 = custom_target(
+ html,
+ input : xml,
+ output : [html] + htmlaliases,
+ command : xslt_cmd + [custom_html_xsl, '@INPUT@'],
+ depend_files : custom_entities_ent,
+ install : want_html,
+ install_dir : join_paths(docdir, 'html'))
+ html_pages += [p2]
+
+ source_xml_files += files(tuple[0] + '.xml')
+ else
+ message('Skipping @0@.@1@ because @2@ is false'.format(stem, section, condition))
+ endif
endforeach
############################################################
have_lxml = run_command(xml_helper_py).returncode() == 0
if not have_lxml
- message('python-lxml not available, not making man page indices')
+ message('python-lxml not available, not making man page indices')
endif
systemd_directives_xml = custom_target(
- 'systemd.directives.xml',
- input : source_xml_files,
- output : 'systemd.directives.xml',
- command : [make_directive_index_py, '@OUTPUT@'] + source_xml_files)
+ 'systemd.directives.xml',
+ input : source_xml_files,
+ output : 'systemd.directives.xml',
+ command : [make_directive_index_py, '@OUTPUT@'] + source_xml_files)
nonindex_xml_files = source_xml_files + [systemd_directives_xml]
systemd_index_xml = custom_target(
- 'systemd.index.xml',
- input : nonindex_xml_files,
- output : 'systemd.index.xml',
- command : [make_man_index_py, '@OUTPUT@'] + nonindex_xml_files)
+ 'systemd.index.xml',
+ input : nonindex_xml_files,
+ output : 'systemd.index.xml',
+ command : [make_man_index_py, '@OUTPUT@'] + nonindex_xml_files)
foreach tuple : [['systemd.directives', '7', systemd_directives_xml],
['systemd.index', '7', systemd_index_xml]]
- stem = tuple[0]
- section = tuple[1]
- xml = tuple[2]
-
- html = stem + '.html'
- man = stem + '.' + section
-
- mandirn = join_paths(get_option('mandir'), 'man' + section)
-
- p1 = custom_target(
- man,
- input : xml,
- output : man,
- command : [xsltproc, '-o', '@OUTPUT0@'] + xsltproc_flags + [custom_man_xsl, '@INPUT@'],
- install : want_man and have_lxml,
- install_dir : mandirn)
- man_pages += [p1]
-
- p2 = custom_target(
- html,
- input : xml,
- output : html,
- command : [xsltproc, '-o', '@OUTPUT0@'] + xsltproc_flags + [custom_html_xsl, '@INPUT@'],
- install : want_html and have_lxml,
- install_dir : join_paths(docdir, 'html'))
- html_pages += [p2]
+ stem = tuple[0]
+ section = tuple[1]
+ xml = tuple[2]
+
+ html = stem + '.html'
+ man = stem + '.' + section
+
+ mandirn = join_paths(get_option('mandir'), 'man' + section)
+
+ p1 = custom_target(
+ man,
+ input : xml,
+ output : man,
+ command : xslt_cmd + [custom_man_xsl, '@INPUT@'],
+ install : want_man and have_lxml,
+ install_dir : mandirn)
+ man_pages += [p1]
+
+ p2 = custom_target(
+ html,
+ input : xml,
+ output : html,
+ command : xslt_cmd + [custom_html_xsl, '@INPUT@'],
+ install : want_html and have_lxml,
+ install_dir : join_paths(docdir, 'html'))
+ html_pages += [p2]
endforeach
man = custom_target('man',