summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-01-27 08:46:42 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-01-27 08:46:42 +0100
commit4c890ad3cc7b3445683d7b52bc00e4a58bef5e94 (patch)
tree2cb6fef6df58cbd6879838d6108dd02cf8ee797b /man/meson.build
parente798ffef82735e047479296ecc58bd8a18a749db (diff)
downloadsystemd-4c890ad3cc7b3445683d7b52bc00e4a58bef5e94.tar.gz
meson: rename target to update-dbus-docs
Very old versions of meson did not include the subdirectory name in the target name, so we started adding various "top-level" custom targets in subdirectories. This was nice because the main meson.build file wasn't as cluttered. But then meson started including the subdir name in the target name. So let's move the definition to the root so we can have all targets named uniformly.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build19
1 files changed, 0 insertions, 19 deletions
diff --git a/man/meson.build b/man/meson.build
index 88e06b384a..327df94c27 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -198,25 +198,6 @@ run_target(
############################################################
-if dbus_docs.length() > 0
- custom_target(
- 'update-dbus-docs',
- output : 'update-dbus-docs',
- command : [update_dbus_docs_py,
- '--build-dir=@0@'.format(project_build_root),
- '@INPUT@'],
- input : dbus_docs)
-
- if conf.get('BUILD_MODE') == 'BUILD_MODE_DEVELOPER'
- test('dbus-docs-fresh',
- update_dbus_docs_py,
- args : ['--build-dir=@0@'.format(project_build_root),
- '--test'] + dbus_docs)
- endif
-endif
-
-############################################################
-
custom_target(
'update-man-rules',
output : 'update-man-rules',