summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-07-31 09:44:11 +0200
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-07-31 21:02:01 +0900
commit5a8b16409240bc95d95f3c19d6f5cd9366e6ccf4 (patch)
tree56ec64572991eddcd452f6f1aaf670d6fe00ce6a /man/meson.build
parent48e0e10ff5196a7b916c72af0107c39b55da2f66 (diff)
downloadsystemd-5a8b16409240bc95d95f3c19d6f5cd9366e6ccf4.tar.gz
meson: drop parens when appending to list
Meson does not care either way, so let's use the simpler syntax. And files() already gives a list, so nesting this in a list wouldn't be necessary even if meson did not flatten everything.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build20
1 files changed, 10 insertions, 10 deletions
diff --git a/man/meson.build b/man/meson.build
index fe19268bcd..9cd93df846 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -47,8 +47,8 @@ foreach tuple : xsltproc.found() ? manpages : []
manaliases = []
htmlaliases = []
foreach alias : aliases
- manaliases += [alias + '.' + section]
- htmlaliases += [alias + '.html']
+ manaliases += alias + '.' + section
+ htmlaliases += alias + '.html'
endforeach
mandirn = join_paths(get_option('mandir'), 'man' + section)
@@ -62,7 +62,7 @@ foreach tuple : xsltproc.found() ? manpages : []
depend_files : custom_entities_ent,
install : want_man,
install_dir : mandirn)
- man_pages += [p1]
+ man_pages += p1
p2 = []
foreach htmlalias : htmlaliases
@@ -75,9 +75,9 @@ foreach tuple : xsltproc.found() ? manpages : []
dst = join_paths(docdir, 'html', htmlalias)
cmd = 'ln -fs @0@ $DESTDIR@1@'.format(html, dst)
meson.add_install_script('sh', '-c', cmd)
- p2 += [link]
+ p2 += link
endif
- html_pages += [link]
+ html_pages += link
endforeach
p3 = custom_target(
@@ -89,7 +89,7 @@ foreach tuple : xsltproc.found() ? manpages : []
depends : p2,
install : want_html,
install_dir : join_paths(docdir, 'html'))
- html_pages += [p3]
+ html_pages += p3
source_xml_files += files(tuple[0] + '.xml')
else
@@ -135,7 +135,7 @@ foreach tuple : xsltproc.found() ? [['systemd.directives', '7', systemd_directiv
command : xslt_cmd + [custom_man_xsl, '@INPUT@'],
install : want_man and have_lxml,
install_dir : mandirn)
- man_pages += [p1]
+ man_pages += p1
p2 = []
if html == 'systemd.index.html'
@@ -149,9 +149,9 @@ foreach tuple : xsltproc.found() ? [['systemd.directives', '7', systemd_directiv
dst = join_paths(docdir, 'html', htmlalias)
cmd = 'ln -fs @0@ $DESTDIR@1@'.format(html, dst)
meson.add_install_script('sh', '-c', cmd)
- p2 += [link]
+ p2 += link
endif
- html_pages += [link]
+ html_pages += link
endif
p3 = custom_target(
@@ -163,7 +163,7 @@ foreach tuple : xsltproc.found() ? [['systemd.directives', '7', systemd_directiv
depends : p2,
install : want_html and have_lxml,
install_dir : join_paths(docdir, 'html'))
- html_pages += [p3]
+ html_pages += p3
endforeach
# cannot use run_target until https://github.com/mesonbuild/meson/issues/1644 is resolved